tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Soto <asot...@gmail.com>
Subject Re: DeltaSpike + Arquillian + Apache TomEE
Date Mon, 02 Jun 2014 06:31:00 GMT
Thanks :)


2014-06-02 0:10 GMT+02:00 Romain Manni-Bucau <rmannibucau@gmail.com>:

> BTW https://issues.apache.org/jira/browse/TOMEE-1234 (even if it is an
> arquillian issue first IMHO)
>
>
>
> Romain Manni-Bucau
> Twitter: @rmannibucau
> Blog: http://rmannibucau.wordpress.com/
> LinkedIn: http://fr.linkedin.com/in/rmannibucau
> Github: https://github.com/rmannibucau
>
>
> 2014-06-01 23:54 GMT+02:00 Romain Manni-Bucau <rmannibucau@gmail.com>:
>
> > That's because tomee-embedded doesn't set contextual classloader for
> @Test
> > methods and no luck deltaspike uses it to find configurations.
> >
> >
> >
> > Romain Manni-Bucau
> > Twitter: @rmannibucau
> > Blog: http://rmannibucau.wordpress.com/
> > LinkedIn: http://fr.linkedin.com/in/rmannibucau
> > Github: https://github.com/rmannibucau
> >
> >
> > 2014-06-01 23:04 GMT+02:00 John D. Ament <john.d.ament@gmail.com>:
> >
> > When you say default is local, do you mean embedded?
> >>
> >> It's possible that when in embedded mode, the extension isn't getting
> >> started.  Can you try explicitly adding it to your archive?
> >>
> >> On Sun, Jun 1, 2014 at 4:51 PM, Alex Soto <asotobu@gmail.com> wrote:
> >> > Hi,
> >> >
> >> > I am writing a tutorial about how to inject properties files in CDI
> >> POJOs
> >> > using DeltaSpike. You can find code here:
> >> >
> https://github.com/tomitribe/community/tree/master/injecting-properties
> >> and
> >> > the test here:
> >> >
> >>
> https://github.com/tomitribe/community/blob/master/injecting-properties/src/test/java/org/superbiz/cdi/properties/MongoDbFactoryTest.java
> >> >
> >> > I am using the Arquillian Embed Adapter for Apache TomEE, and it is
> >> funny
> >> > one thing I have seen. If I run the test over Servlet 3.0 protocol
> then
> >> it
> >> > works, but if I run the test using the default (which is local) it
> >> throws a
> >> > NullPointerException (basically because values are not injected). Any
> >> idea?
> >> > Probably something related with classpath.
> >> >
> >> > --
> >> > +----------------------------------------------------------+
> >> >   Alex Soto Bueno
> >> >   www.lordofthejars.com
> >> > +----------------------------------------------------------+
> >>
> >
> >
>



-- 
+----------------------------------------------------------+
  Alex Soto Bueno - Computer Engineer
  www.lordofthejars.com
+----------------------------------------------------------+

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message