tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <frank.spr...@ubs.com>
Subject RE: TomEE Dropin for Tomcat - Service unavailable after restart
Date Wed, 23 Jul 2014 09:16:47 GMT
Thanks for your reply,



@ JLouis

At the moment I do not have the opportunity to go with with TomEE full package ;-(

I'm in an environment with preinstalled Tomcat (7.0.54). I also have not the ability to perform
manual steps during the delivery (installer webapp).

Do you know what exactly and where configs will be changed by this installer webapp in Tomcat?
At the moment it works without this manual steps (Tested with Tomcat 7.0.54 and tome-plus-webapp-1.7.0
SNAPSHOT of today) .



@Romain

I added the overlay dependency to my project.


<dependency>
<groupId>org.apache.openejb</groupId>
<artifactId>tomee-overlay-runner</artifactId>
<version>1.7.0-SNAPSHOT</version>
</dependency>


Is this another workaround except the JLouis fix? Or what is the benefit of it?



Regards, Frank









-----Original Message-----

From: Romain Manni-Bucau [mailto:rmannibucau@gmail.com]

Sent: Mittwoch, 23. Juli 2014 10:24

To: users@tomee.apache.org<mailto:users@tomee.apache.org>

Subject: Re: TomEE Dropin for Tomcat - Service unavailable after restart



Hi



you are right and JL fix would work if you can update/configure the container otherwise no
way.





side note: we added a jar to avoid it doing an overlay of tomee war with your war and forcing
tomee to boot tomee-overlay-runner, just add it in your overlay of tomee and it will work









Romain Manni-Bucau

Twitter: @rmannibucau

Blog: http://rmannibucau.wordpress.com/

LinkedIn: http://fr.linkedin.com/in/rmannibucau

Github: https://github.com/rmannibucau





2014-07-23 10:02 GMT+02:00 Jean-Louis Monteiro <jlmonteiro@tomitribe.com<mailto:jlmonteiro@tomitribe.com>>:



> Hi,

>

> This is because you did probably forget the listener.

> So depending on the order the webapps are loaded, TomEE will not be

> notified.

>

> The listener make it possible to start TomEE during Tomcat lifecycle

> and start process, so that all webapps being deployed are after TomEE.

> Follow the instructions here

> http://tomee.apache.org/installation-drop-in-war.html

> And don't forget to run the installer so that the listener will get

> installed.

>

> That said, if possible i would recommend using TomEE full package

> instead of the drop in war approach.

> Even between small tomcat version, some incompatibilities may appear

> and break some parts. And that approach has some drawbacks in terms of

> Java EE Web Profile compliancy.

> Last but not least, it harder to use well known Tomcat tools (Eclipse

> WTP,

> etc) with that approach cause you always need to add the webapp, the

> listener and the jars in your classpath.

>

> Hope it helps

> JLouis

>

>

> --

> Jean-Louis Monteiro

> http://twitter.com/jlouismonteiro

> http://www.tomitribe.com

>

>

> On Wed, Jul 23, 2014 at 9:54 AM, <frank.sprich@ubs.com<mailto:frank.sprich@ubs.com>>
wrote:

>

> > Hello TomEE User Community,

> >

> >

> >

> > At the moment I have a little problem with the TomEE Dropin for

> > Tomcat (nightly build: tomee-plus-webapp-1.7.0-20140709.113339-49.war).

> >

> >

> >

> > The Situation:

> >

> > ·         I've written a REST service (JAX-RS/EJB/JPA). When I start

> > Tomcat with the already inserted TomEE Dropin (first step), my

> > service deploys after that without problems (in a second step) and

> > is accessible via GET method.

> >

> > ·         The Problem starts when I restart the server with the already

> > deployed REST service and TomEE Dropin in the webapps folder.

> >

> > The TomEE Dropin loads fine - no problem. But my REST service

> > doesn't appear to be loaded. Only after undeploy/deploy of my

> > service within the running server the service is accessible again.

> >

> >

> >

> > Interesting Behavior:

> >

> > ·         I renamed my REST service project to start with "z"

> > alphabetical after "t" which is the first letter of tomee.war and my

> > REST service loads fine after a restart of the server.

> >

> >

> >

> > Are there any suggestions to this? So that I do not have to rename

> > my projects/services to start with a letter after "t" for tomee.war?

> >

> >

> >

> > Thank you in advance for your feedback.

> >

> >

> >

> > Regards, Frank

> >

> >

> >

> >

> > E-mails can involve SUBSTANTIAL RISKS, e.g. lack of confidentiality,

> > potential manipulation of contents and/or sender's address,

> > incorrect recipient (misdirection), viruses etc. Based on previous

> > e-mail correspondence with you and/or an agreement reached with you,

> > UBS

> considers

> > itself authorized to contact you via e-mail. UBS assumes no

> responsibility

> > for any loss or damage resulting from the use of e-mails.

> > UBS reserves the right to retain all messages. Messages are

> > protected and accessed only in legally justified cases.

> > Privacy statements:

> > http://www.ubs.com/global/en/legalinfo2/privacy.html

> >

>
Mime
View raw message