tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bjorn Danielsson <bjorn-apa...@lists.cuspycode.com>
Subject Re: Spooky org.terracotta.quartz.skipUpdateCheck
Date Mon, 21 Jul 2014 17:44:31 GMT
TomEE undeploys the first copy before redeploying the new one,
according to catalina.out. Is redeployment by dropping a new
version of the war file into tomee/webapps not supported?

And it makes no difference if I first undeploy the first copy by
deleting the war file, then wait a few minutes and watch how tomee
undeploys it, then I deploy it again by copying the same war file
to webapps. The same spooky behaviour is manifested:

With "org.terracotta.quartz.skipUpdateCheck=true" Quartz stops
working, without it everything works as expected.

-- 
Bjorn Danielsson
Cuspy Code AB


Romain Manni-Bucau <rmannibucau@gmail.com> wrote:
> without undeploying the other copy? then there is an EJB conflict so
> doesn't shock me it doesn't work
>
>
>
> Romain Manni-Bucau
> Twitter: @rmannibucau
> Blog: http://rmannibucau.wordpress.com/
> LinkedIn: http://fr.linkedin.com/in/rmannibucau
> Github: https://github.com/rmannibucau
>
>
> 2014-07-21 19:22 GMT+02:00 Bjorn Danielsson <
> bjorn-apache@lists.cuspycode.com>:
>
>> I redeploy by copying it a second time to tomee/webapps as
>> explained here:
>>
>>
>> https://github.com/cuspycode/apache-stuff/blob/master/schedule-bug/readme.txt
>>
>> Just touching the .war also reproduces it for me.
>>
>> --
>> Bjorn Danielsson
>> Cuspy Code AB
>>
>>
>> Romain Manni-Bucau <rmannibucau@gmail.com> wrote:
>> > How do you deploy it? deploying it at startup then hitting several times
>> > reload works fine
>> >
>> >
>> >
>> > Romain Manni-Bucau
>> > Twitter: @rmannibucau
>> > Blog: http://rmannibucau.wordpress.com/
>> > LinkedIn: http://fr.linkedin.com/in/rmannibucau
>> > Github: https://github.com/rmannibucau
>> >
>> >
>> > 2014-07-21 18:52 GMT+02:00 Bjorn Danielsson <
>> > bjorn-apache@lists.cuspycode.com>:
>> >
>> >> Andy,
>> >>
>> >> No I was just trying to be clever and give a subversion link to
>> >> a Github subdirectory. It works with svn but apparently not in
>> >> a browser. Try the root link instead and ignore the other stuff:
>> >>
>> >> https://github.com/cuspycode/apache-stuff
>> >>
>> >> --
>> >> Bjorn Danielsson
>> >> Cuspy Code AB
>> >>
>> >>
>> >> Andy Gumbrecht <agumbrecht@tomitribe.com> wrote:
>> >> > Bjorn,
>> >> >
>> >> > I get a 404 on the link, did you kill it already?
>> >> >
>> >> > Andy.
>> >> >
>> >> > On 21/07/2014 16:39, Bjorn Danielsson wrote:
>> >> >> I checked the URL connectivity with curl, and I checked the 302-
>> >> >> redirect host, and both are responsive on the machine in question.
>> >> >> Then I temporarily added bogus routes to both hosts, and nothing
>> >> >> changed. There are no delays due to failed connection attempts.
>> >> >> In fact the webapp starts as usual, and beans and servlets are
>> >> >> responsive, it's just that the timers stop working.
>> >> >>
>> >> >> I noticed one more thing now when taking a second look at the logs.
>> >> >> When I redeploy with skipUpdateCheck=true I get log messages about
>> >> >> QuartzScheduler shutting down during undeployment and about one
>> >> >> second later it is initialized during deployment. With an empty
>> >> >> system.properties I get no such messages during redeployment,
>> >> >> only at start and stop of tomee itself.
>> >> >>
>> >> >> Here is a small ant project that reproduces the behaviour:
>> >> >>
>> >> >> svn co https://github.com/cuspycode/apache-stuff/trunk/schedule-bug
>> >> >>
>> >>
>>

Mime
View raw message