tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tamás Kimmel <kumm0...@gmail.com>
Subject Re: tomee-maven-plugin @PersistenceUnit multiple matches
Date Thu, 17 Jul 2014 10:41:21 GMT
Yes, tried moving it, and leaving in resources too.
Eclipselink does not log an exact path where is it looking for
eclipselink-orm.xml. Even on FINEST level.

But found a workaround. It finds the file from a jar in WEB-INF/lib, just
have to load in persistence xml via <jar-file>.
So now i have a persistence.xml in WEB-INF, and an eclipselink-orm.xml in a
jar module's resources/META-INF.
I'm so proud of it :)

Now my app is up and running.

Thanks!


2014-07-17 11:06 GMT+02:00 Jean-Louis Monteiro <jlmonteiro@tomitribe.com>:

> Did you also moved the orm?
> As per the spec, it should be relative to the persistence archive, so I
> guess, Eclipselink is looking for it at WEB-INF/, isn't it?
>
> --
> Jean-Louis Monteiro
> http://twitter.com/jlouismonteiro
> http://www.tomitribe.com
>
>
> On Thu, Jul 17, 2014 at 11:04 AM, Tamás Kimmel <kumm0307@gmail.com> wrote:
>
> > Thank you guys, even me agree it is not a blocker bug.
> >
> > Romain: I don't want to be the man who force you work at midnight :)
> >
> > I've hacked liquibase. Overridden a method not to fail when
> > classLoader.getResources(path) returns more element.
> > Now it works.
> > But i've run into an other problem .... :P
> > eclipselink does not find eclipselink-orm.xml after moving my
> > persistence.xml :)
> >
> >
> >
> >
> > 2014-07-17 10:27 GMT+02:00 Jean-Louis Monteiro <jlmonteiro@tomitribe.com
> >:
> >
> > > lol
> > >
> > > --
> > > Jean-Louis Monteiro
> > > http://twitter.com/jlouismonteiro
> > > http://www.tomitribe.com
> > >
> > >
> > > On Thu, Jul 17, 2014 at 10:20 AM, Romain Manni-Bucau <
> > > rmannibucau@gmail.com>
> > > wrote:
> > >
> > > > yep that's the open point, I can't fix it now ($dayjob) but not a
> > > > blocking for a release since that's something new and still a bit
> > > > experimental (but I'm already addicted ;)).
> > > >
> > > >
> > > > Romain Manni-Bucau
> > > > Twitter: @rmannibucau
> > > > Blog: http://rmannibucau.wordpress.com/
> > > > LinkedIn: http://fr.linkedin.com/in/rmannibucau
> > > > Github: https://github.com/rmannibucau
> > > >
> > > >
> > > > 2014-07-17 10:16 GMT+02:00 Jean-Louis Monteiro <
> > jlmonteiro@tomitribe.com
> > > >:
> > > > > We can probably merge for a 1.7.1 I think.
> > > > > Not really a big deal and we should get more feedback from users
> that
> > > > > requires a maintenance release.
> > > > >
> > > > > JLouis
> > > > >
> > > > > --
> > > > > Jean-Louis Monteiro
> > > > > http://twitter.com/jlouismonteiro
> > > > > http://www.tomitribe.com
> > > > >
> > > > >
> > > > > On Thu, Jul 17, 2014 at 10:12 AM, Romain Manni-Bucau <
> > > > rmannibucau@gmail.com>
> > > > > wrote:
> > > > >
> > > > >> Yes, that's the fix to do. Hopefully tonight on trunk (then don't
> > know
> > > > >> if it will be mergeable with 1.7 or too late)
> > > > >>
> > > > >>
> > > > >> Romain Manni-Bucau
> > > > >> Twitter: @rmannibucau
> > > > >> Blog: http://rmannibucau.wordpress.com/
> > > > >> LinkedIn: http://fr.linkedin.com/in/rmannibucau
> > > > >> Github: https://github.com/rmannibucau
> > > > >>
> > > > >>
> > > > >> 2014-07-17 10:09 GMT+02:00 Tamás Kimmel <kumm0307@gmail.com>:
> > > > >> > Thanks,
> > > > >> > WEB-INF/persistence.xml works.
> > > > >> >
> > > > >> > Right after getting this work, i've run into another problem
> > > > >> > I get an error from liquibase.
> > > > >> > Error Reading Migration File: Found 2 files that match
> > changelog.xml
> > > > >> >
> > > > >> > Just for the enhancement in the future: Any file in resources
> can
> > > > cause a
> > > > >> > similar problem.
> > > > >> >
> > > > >> >
> > > > >> >
> > > > >> > 2014-07-16 19:43 GMT+02:00 Romain Manni-Bucau <
> > > rmannibucau@gmail.com
> > > > >:
> > > > >> >
> > > > >> >> Hi
> > > > >> >>
> > > > >> >> yes, this is "expected" since persistence.xml is in
> > > > src/main/resources
> > > > >> >> and target/classes, personally I put it in
> > src/main/webapp/WEB-INF
> > > > >> >>
> > > > >> >> If I find time I'll enhance it but ATM on another thing
> > > > >> >>
> > > > >> >>
> > > > >> >>
> > > > >> >> Romain Manni-Bucau
> > > > >> >> Twitter: @rmannibucau
> > > > >> >> Blog: http://rmannibucau.wordpress.com/
> > > > >> >> LinkedIn: http://fr.linkedin.com/in/rmannibucau
> > > > >> >> Github: https://github.com/rmannibucau
> > > > >> >>
> > > > >> >>
> > > > >> >> 2014-07-16 19:29 GMT+02:00 Tamás Kimmel <kumm0307@gmail.com>:
> > > > >> >> > Hi!
> > > > >> >> >
> > > > >> >> > I'm experimenting with tomee-maven-plugin 1.7.0-SNAPSHOT,
and
> > run
> > > > >> into a
> > > > >> >> > problem.
> > > > >> >> >
> > > > >> >> > If i put a src/main/resources/META-INF/persistence.xml
in my
> > > simple
> > > > >> web
> > > > >> >> > project, and use
> > > > >> >> > <webappDefaultConfig>true</webappDefaultConfig>
> > > > >> >> > tomee doubles my persistence unit.
> > > > >> >> >
> > > > >> >> > SEVERE - FAIL ... myapp-web: @PersistenceUnit unitName
has
> > > multiple
> > > > >> >> > matches: unitName "default" has 2 possible matches.
> > > > >> >> >
> > > > >> >> > I think the problem somewhere around externalRepositories
and
> > > some
> > > > >> >> > classloader magic.
> > > > >> >> >
> > > > >> >> > When i knock this out with a dummy setting like
this:
> > > > >> >> > <externalRepositories>
> > > > >> >> >
> > > > >> >> > <externalRepository>target/emptydir</externalRepository>
> > > > >> >> > </externalRepositories>
> > > > >> >> >
> > > > >> >> > My application deploys. ( but i lost class hotswapping
)
> > > > >> >> >
> > > > >> >> > Are there anybody who tried webappDefaultConfig
with a war
> > > > containing
> > > > >> a
> > > > >> >> > persistence unit?
> > > > >> >>
> > > > >>
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message