tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tamás Kimmel <kumm0...@gmail.com>
Subject tomee-maven-plugin webappDefaultConfig broken
Date Thu, 24 Jul 2014 11:35:13 GMT
Hi!

I know this is an experimental function.
I'm just sending a signal, it stopped to work.
Last known working version is snapshot at 20140716.
Last known broken version is snapshot at 20140722.

I get this stacktrace on tomee:run:
INFO - Deployed
Application(path=/home/kumm/Workspace/_try/mavenwebproject/target/apache-tomee/webapps/mavenwebproject-1.0-SNAPSHOT)
SEVERE - ContainerBase.addChild: start:
org.apache.catalina.LifecycleException: Failed to start component
[StandardEngine[Catalina].StandardHost[localhost].StandardContext[/mavenwebproject-1.0-SNAPSHOT]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
at
org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:632)
at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:1083)
at
org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1880)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
at java.util.concurrent.FutureTask.run(FutureTask.java:262)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)
Caused by: java.lang.NullPointerException
at org.apache.openejb.config.NewLoaderLogic.skip(NewLoaderLogic.java:180)
at org.apache.openejb.config.NewLoaderLogic.skip(NewLoaderLogic.java:176)
at
org.apache.tomee.catalina.OpenEJBContextConfig.processAnnotationsUrl(OpenEJBContextConfig.java:524)
at
org.apache.catalina.startup.ContextConfig.webConfig(ContextConfig.java:1298)
at
org.apache.tomee.catalina.OpenEJBContextConfig.webConfig(OpenEJBContextConfig.java:366)
at
org.apache.catalina.startup.ContextConfig.configureStart(ContextConfig.java:876)
at
org.apache.tomee.catalina.OpenEJBContextConfig.configureStart(OpenEJBContextConfig.java:115)
at
org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:374)
at
org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
at
org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:90)
at
org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5355)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
... 10 more
SEVERE - Error deploying web application archive
/home/kumm/Workspace/_try/mavenwebproject/target/apache-tomee/webapps/mavenwebproject-1.0-SNAPSHOT.war

My test project is an empty maven web project created by maven
archetype:generate.
( mvn -DarchetypeGroupId=org.codehaus.mojo.archetypes
-DarchetypeArtifactId=webapp-javaee6 -DarchetypeVersion=1.5
-DgroupId=com.acme -DartifactId=mavenwebproject -Dversion=1.0-SNAPSHOT
-Dpackage=com.acme Dbasedir=/home/kumm/Workspace/_try archetype:generate )

plugin in pom.xml:
<plugin>
                <groupId>org.apache.openejb.maven</groupId>
                <artifactId>tomee-maven-plugin</artifactId>
                <version>1.7.0-SNAPSHOT</version>
                <configuration>
                    <tomeeClassifier>webprofile</tomeeClassifier>
                    <simpleLog>true</simpleLog>
                    <webappDefaultConfig>true</webappDefaultConfig>
                </configuration>
</plugin>

Without line "<webappDefaultConfig>true</webappDefaultConfig>" everything
works as expected.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message