tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Soto <asot...@gmail.com>
Subject Re: XA datasource in tomee.xml
Date Mon, 21 Jul 2014 14:59:20 GMT
It seems that this approach TOMEE-1169 only works for TomEE 1.7.0.

If you want to use tomee.xml approach you may need to translate system
properties to tomee.xml, so for example:

setProperty("db1XA", "new://Resource?type=DataSource");
setProperty("db1XA.XaDataSource", "db1XAUnderlying");
            setProperty("db1XA.DataSourceCreator", "dbcp-alternative"


Needs to be translated to:

<tomee>
<Resource id="db1XA" type="DataSource">
  XaDataSource db1XAunderlying
  DataSourceCreator dbcp-alternative
</Resource>

Here there is an answer of Romain about this topic
http://tomee-openejb.979440.n4.nabble.com/Is-Tomee-not-support-XADataSource-td4642705.html

Don't know if it helps you :)



2014-07-21 16:47 GMT+02:00 Trevor Stevens <tstevens@me.com>:

> What is the correct syntax to create an XA datasource within tomee.xml? I
> have tried to follow the advice on some previous mailing list posts and
> also using the changes introduced in
> https://issues.apache.org/jira/browse/TOMEE-1169 without luck.
>
> Trevor Stevenststevens@me.com
>
>


-- 
+----------------------------------------------------------+
  Alex Soto Bueno - Computer Engineer
  www.lordofthejars.com
+----------------------------------------------------------+

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message