tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Steen <ad...@rmt.com.au>
Subject Legacy Quartz and Tomee 1.7.1+
Date Mon, 20 Oct 2014 09:16:40 GMT
Hi

I was previously using Tomee 1.5.2 for our WebApp and was able to successful use a legacy
version of quartz alongside whatever version Tomee 1.5.2 was using.

I have downloaded Tomee 1.7.1 Plus and was pleasantly surprised our app just ran out of the
box, my joy was short lived when I tried to access some legacy information through the older
version of Quartz.

I would have thought adding "openejb.classloader.forced-load=org.quartz" to my system.properties
but I still get the following exception when try to access the Scheduler for the first time.

Exception: ThreadPool class 'org.quartz.simpl.SimpleThreadPool' props could not be configured.
<snip>
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:220)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)
        at org.apache.tomee.catalina.OpenEJBValve.invoke(OpenEJBValve.java:44)
        at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:501)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
        at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:950)
        at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:312)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:408)
        at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1070)
        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:611)
        at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:316)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
        at java.lang.Thread.run(Thread.java:745)
Caused by: org.quartz.SchedulerException: ThreadPool class 'org.quartz.simpl.SimpleThreadPool'
props could not be configured. [See nested exception: java.lang.NoSuchMethodException: No
setter for property 'threadsInheritContextClassLoa
derOfInitializingThread']
        at org.quartz.impl.StdSchedulerFactory.instantiate(StdSchedulerFactory.java:462)
        at org.quartz.impl.StdSchedulerFactory.getScheduler(StdSchedulerFactory.java:827)

My quartz.properties file

<snip>

org.quartz.threadPool.class = org.quartz.simpl.SimpleThreadPool
org.quartz.threadPool.threadCount = 3
org.quartz.threadPool.threadPriority = 4

<snip>

org.quartz.jobStore.class = org.quartz.impl.jdbcjobstore.JobStoreCMT
org.quartz.jobStore.driverDelegateClass = au.com.rmt.scheduler.jdbcjobstore.oracle.RMTOracleDelegate
org.quartz.jobStore.dataSource = oracle
org.quartz.jobStore.tablePrefix = QRTZ_
org.quartz.jobStore.instanceId = 1

<snip>

I have tried a number of things with no success, and google has been any help either, any
ideas where to check next?

Regards,

Adam Steen


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message