tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: TomEE JavaMail problems
Date Sun, 19 Oct 2014 11:46:18 GMT
2014-10-19 13:44 GMT+02:00 Howard W. Smith, Jr. <smithh032772@gmail.com>:
> You did the right thing. For years, I have been posting to this list about
> my issues with geronimo javamail (which is shipped/bundled with tomee+) and
> the workaround is to remove-and-replace geronimo javamail JAR with (Oracle)
> JavaMail JAR.
>

Guys please help us to resolve it, we have many users (and us as well
;)) not having issues to we need you to dig into it.

> Now, my endusers don't like the few seconds wait/delay that it takes to
> sendMail via (Oracle) JavaMail, so I am using MessageDrivenBean via Apache
> MQ (bundled with TomEE+) to send the mail after user click Send Mail button
> in webapp.
>

@Asynchronous instead of a JMS MDB looks more appropriated ;)

>
> On Sat, Oct 18, 2014 at 9:59 PM, iluvtr <iluvtr@gmail.com> wrote:
>
>> I use a Tomcat 7, recently I considered to use TomEE in order to get full
>> power of Java EE without all that plumbing that comes with plain Tomcat.
>>
>> The bad news came with email sending, because compared it was taking a
>> long,
>> long time compared with plain Tomcat with Oracle JavaMail.
>>
>> Sending email with TomEE: 116393 ms
>> Sending email with Tomcat 7: 4557 ms
>>
>> I thought it was a bug and filed here
>> https://issues.apache.org/jira/browse/TOMEE-1413, but TomEE team couldn't
>> reproduce the failure and told me that maybe it was some network problem.
>>
>> I have disabled antivirus, firewall, everything, and tested in two
>> different
>> computers one in my home and other in my work, but still having that
>> problem,
>> This problem doesn't occur in plain Tomcat 7, I even tested the same code
>> in
>> Glassfish 3.1 and works pretty well there.
>>
>> Recently I replaced Geronimo JavaMail with Oracle JavaMail and all my
>> problems went away, so I think that this problem has something to do with
>> Geronimo implementation
>>
>>     I added geronimo-osgi-locator-1.1.jar to TOMEE/lib
>>     I removed geronimo-javamail_1.4_mail-1.8.3.jar in TOMEE/lib
>>     I added mail.jar (Oracle JavaMail)
>>
>>
>> What do you think: Is the change I made will affect badly TomEE ?
>> Thank you so much
>>
>>
>>
>>
>>
>> --
>> View this message in context:
>> http://tomee-openejb.979440.n4.nabble.com/TomEE-JavaMail-problems-tp4672429.html
>> Sent from the TomEE Users mailing list archive at Nabble.com.
>>

Mime
View raw message