tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: Apache TomEE 1.7.1 and Arquillian Persistence Extension Alpha7
Date Wed, 01 Oct 2014 10:34:37 GMT
Hi

you can exclude openejb-transaction-provider or exclude (better)
arquillian-transaction-jta.

It didn't work in embedded mode with version 1.0.0.Alpha3 cause
embedded mode is not supported AFAIK, that's why you have to use the
workaround I mentionned in several threads/posts. Do you think it is
fixed in alpha7.


Romain Manni-Bucau
Twitter: @rmannibucau
Blog: http://rmannibucau.wordpress.com/
LinkedIn: http://fr.linkedin.com/in/rmannibucau
Github: https://github.com/rmannibucau


2014-10-01 11:29 GMT+02:00 Alex Soto <asotobu@gmail.com>:
> Hi guys,
>
> I am developing an example of Arquillian Persistence Extension (Alpha7)
> with Apache TomEE 1.7.1.
>
> First I have tried to run the example using Apache TomEE embedded adapter.
> AndI have found that the dataset was not populated to database. BEfore
> trying to know if the problem could be at TomEE or Arquillian or in both,I
> have tried the same example but using TomEE Remote adapter. In that case,
> next exception is thrown:
>
> Multiple service implementations found for interface
> org.jboss.arquillian.transaction.spi.provider.TransactionProvider.
> org.jboss.arquillian.transaction.jta.provider.JtaTransactionProvider,
> org.apache.openejb.arquillian.transaction.OpenEJBTransactionProvider
>
> Yes I know the cause (message is quite informative), and probably this is
> exactly the same why embedded tomee does not work.
>
> Do you have any advice to fix this problem in a clear way?
>
> Side note: APE Alpha7 added as a project arquillian transaction so maybe
> for this reason the problem has not been appeared since now.
>
> Alex.
>
> --
> +----------------------------------------------------------+
>   Alex Soto Bueno - Computer Engineer
>   www.lordofthejars.com
> +----------------------------------------------------------+

Mime
View raw message