tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nuno <nunofrrpsim...@gmail.com>
Subject TomEE and Maven
Date Fri, 16 Jan 2015 10:48:21 GMT
Hi

I'm experiencing some dificulties regarding tomee:deploy goal. The behavior
i get is not the expected. when i use it the deploy is made, but some
behaviors atferwards are particularly unsual. For instance i'm not able to
undeploy the war either by tomee:undeploy goal or via the tomcat
administration page. Finally if i stop-and-start the server using shutdown
and startup shell scripts(yes the server is in linux, Ubuntu more exactly)
the deployed war desapears as if it wasn't deployed in first place.

Since I'm a begineer either using maven and TomEE i supose i have something
configurated wrongly on the pom. This is the pom:

<project xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd">
  <modelVersion>4.0.0</modelVersion>
  <groupId>com.example</groupId>
  <artifactId>example</artifactId>
  <version>001-SNAPSHOT</version>  
  <packaging>war</packaging>
  <name>example</name>
  <build>
   <plugins>
    <plugin>
      <artifactId>maven-compiler-plugin</artifactId>
        <configuration>
          <source>1.6</source>
          <target>1.6</target>
          <goalPrefix>compiler</goalPrefix>
        </configuration>
    </plugin>
    <plugin>  
     <groupId>org.apache.openejb.maven</groupId>  
     <artifactId>tomee-maven-plugin</artifactId>  
     <version>1.7.1</version>  
     <configuration>  
      <tomeeVersion>1.7.1</tomeeVersion>
     
<path>C:\Eclipse\workspace\repository\example\target\example-001-SNAPSHOT.war</path>
      <tomeeHost>10.0.1.78</tomeeHost>
      <tomeeHttpPort>8080</tomeeHttpPort>
     </configuration>  
    </plugin>  
    <plugin>
     <groupId>org.apache.maven.plugins</groupId>
     <artifactId>maven-release-plugin</artifactId>
     <version>2.5.1</version>
     <configuration>
      <useReleaseProfile>false</useReleaseProfile>
       <goals>deploy</goals>          
     </configuration>
    </plugin>
    <plugin>
      <groupId>org.sonatype.plugins</groupId>
      <artifactId>nexus-staging-maven-plugin</artifactId>
      <version>1.6.3</version>
      <extensions>true</extensions>
      <configuration>
        <serverId>nexus</serverId>
       
<nexusUrl>http://10.0.1.79:8081/nexus/content/repositories/example</nexusUrl>
      </configuration>
     </plugin>
   </plugins>
  </build>
  <dependencies>
   <dependency>
	<groupId>org.apache.maven.plugins</groupId>
	<artifactId>maven-war-plugin</artifactId>
	<version>2.5</version>
   </dependency>
    <dependency>
        <groupId>com.sun.faces</groupId>
        <artifactId>jsf-api</artifactId>
        <version>2.2.2</version>
    </dependency>
    <dependency>
        <groupId>com.sun.faces</groupId>
        <artifactId>jsf-impl</artifactId>
        <version>2.2.2</version>
    </dependency>
    <dependency>
        <groupId>javax.servlet</groupId>
        <artifactId>javax.servlet-api</artifactId>
        <version>3.0.1</version>
    </dependency>
    <dependency>
	 	<groupId>org.apache.commons</groupId>
	 	<artifactId>commons-io</artifactId>
	 	<version>1.3.2</version>
	</dependency>
	<dependency>
		<groupId>commons-fileupload</groupId>
		<artifactId>commons-fileupload</artifactId>
		<version>1.3.1</version>
	</dependency>
    <dependency>
        <groupId>org.primefaces</groupId>
        <artifactId>primefaces</artifactId>
        <version>5.1</version>
    </dependency>
    <dependency>
	 	<groupId>org.mongodb</groupId>
	 	<artifactId>mongo-java-driver</artifactId>
	 	<version>2.12.4</version>
	</dependency>
	<dependency>
		<groupId>javax.el</groupId>
		<artifactId>el-api</artifactId>
		<version>2.2</version>
	</dependency>
	<dependency>
		<groupId>org.glassfish.web</groupId>
		<artifactId>el-impl</artifactId>
		<version>2.2</version>
	</dependency>
	<dependency>
		<groupId>org.apache.openejb</groupId>
		<artifactId>javaee-api</artifactId>
		<version>6.0-6</version>
	</dependency>
  </dependencies>
  <distributionManagement>
   <snapshotRepository>
    <id>nexus</id>
    <url>http://10.0.1.79:8081/nexus/content/repositories/example</url>
   </snapshotRepository>
  </distributionManagement>  
</project>

the .../.m2/settings.xml is as follows:

<settings>
  <servers>
   <server>
     <id>nexus</id>
     <username>********</username>
     <password>**************</password>
   </server>
  </servers>
  <mirrors>
    <mirror>
      
      <id>nexus</id>
      <mirrorOf>*</mirrorOf>
      <url>http://10.0.1.79:8081/nexus/content/groups/public</url>
    </mirror>
  </mirrors>
  <profiles>
    <profile>
      <id>nexus</id>
      
      
      <repositories>
        <repository>
          <id>central</id>
          <url>http://central</url>
          <releases><enabled>true</enabled></releases>
          <snapshots><enabled>true</enabled></snapshots>
        </repository>
		<repository>
          <id>primefaces-repo</id>
          <url>http://primefaces-repo</url>
          <releases><enabled>true</enabled></releases>
          <snapshots><enabled>true</enabled></snapshots>
        </repository>
		<repository>
			<id>sun</id>
			<url>http://download.java.net/maven/2/</url>
		</repository>
      </repositories>
     <pluginRepositories>
        <pluginRepository>
          <id>central</id>
          <url>http://central</url>
          <releases><enabled>true</enabled></releases>
          <snapshots><enabled>true</enabled></snapshots>
        </pluginRepository>
		<pluginRepository>
          <id>primefaces-repo</id>
          <url>http://primefaces-repo</url>
          <releases><enabled>true</enabled></releases>
          <snapshots><enabled>true</enabled></snapshots>
        </pluginRepository>
      </pluginRepositories>
    </profile>
  </profiles>
  <activeProfiles>
    
    <activeProfile>nexus</activeProfile>
  </activeProfiles>
</settings>

would you please explain me what can i be doing wrongly?

Thank's in advance for any help you can give me.



--
View this message in context: http://tomee-openejb.979440.n4.nabble.com/TomEE-and-Maven-tp4673409.html
Sent from the TomEE Users mailing list archive at Nabble.com.

Mime
View raw message