tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felipe Jaekel <fkjae...@gmail.com>
Subject Re: ActiveMQ web console
Date Wed, 07 Jan 2015 12:34:31 GMT
Hi,

localhost.log had the details, my bad

It's a TextMessage, it contains a JSON.

I'm getting a java.lang.NoClassDefFoundError:
org/apache/commons/lang/StringEscapeUtils.

*/activemq-web-console-5.10.0/WEB-INF/lib* has commons lang 2.6 and
*TomEE/lib* has commons lang 3.3.2

I deleted commons lang 2.6 from TomEE because I thought it wouldn't be
necessary. I tried to copy it back and restarted the server, but the
"poison message" was lost. I guess it's because by default TomEE broker is
not persistent, right? So I changed it to this:

BrokerXmlConfig =
broker:(tcp://localhost:61616)?useJmx=true&amp;persistent=true&amp;usekahadb=true

ActiveMQ is still working, but now all pages in the activemq web console
are empty, like there were no brokers running, even if I change the broker
config back to default.

Any ideas?

Thanks

2015-01-05 14:48 GMT-02:00 Romain Manni-Bucau <rmannibucau@gmail.com>:

> Hi,
>
> and *.log neither?
>
> Is it a portable message (ie not an ObjectMessage)?
>
>
> Romain Manni-Bucau
> @rmannibucau
> http://www.tomitribe.com
> http://rmannibucau.wordpress.com
> https://github.com/rmannibucau
>
>
> 2015-01-05 17:01 GMT+01:00 Felipe Jaekel <fkjaekel@gmail.com>:
> > Hi,
> >
> > I'll reply the same email to keep the context.
> >
> > I thought the activemq webconsole was working 100%, but today I needed to
> > see details of a o message that is failing to be processed. I'm able to
> > browse the messages on the queue, but when I click on the link with the
> > message id I get the same Exception occurred while processing this
> request,
> > check the log for more information! error message, but there is nothing
> in
> > catalina.out.
> >
> > Any ideas?
> >
> > Thanks
> >
> > 2014-10-23 14:55 GMT-02:00 Felipe Jaekel <fkjaekel@gmail.com>:
> >
> >> Removing activemq-spring-5.10.0.jar and activemq-web-5.10.0.jar from the
> >> server lib solved the problem.
> >>
> >> To secure it I added a security constraint to the web.xml of the
> exploded
> >> war. Is there a better way?
> >>
> >> Thanks
> >>
> >> 2014-10-22 16:59 GMT-02:00 Romain Manni-Bucau <
> rmannibucau@tomitribe.com>:
> >>
> >> Here the steps:
> >>>
> >>> 1) put activemq-web-console-5.10.0.war in webapps/
> >>> 2) in conf/system.properties set: webconsole.type = invm
> >>> 3) ensure you have in conf/system.properties or tomee.xml a broker:
> >>>
> >>> <Resource id="MyJmsResourceAdapter" type="ActiveMQResourceAdapter">
> >>>   BrokerXmlConfig =  broker:(tcp://localhost:61616)
> >>> </Resource>
> >>>
> >>> 4) start :)
> >>> Romain Manni-Bucau
> >>> Twitter: @rmannibucau
> >>> Blog: http://rmannibucau.wordpress.com/
> >>> LinkedIn: http://fr.linkedin.com/in/rmannibucau
> >>> Github: https://github.com/rmannibucau
> >>>
> >>>
> >>>
> >>> 2014-10-22 19:02 GMT+02:00 Felipe Jaekel <fkjaekel@gmail.com>:
> >>> > Hi
> >>> >
> >>> > I made the modifications to system.properties, copied
> >>> > activemq-spring-5.10.0.jar and activemq-web-5.10.0.jar to server lib
> and
> >>> > deployed activemq-web-console-5.10.0.war through the manager app.
> >>> >
> >>> > When I access it I see this message: Exception occurred while
> processing
> >>> > this request, check the log for more information!
> >>> >
> >>> > But catalina.out has nothing about it.
> >>> >
> >>> > Any ideas?
> >>> >
> >>> > 2014-10-22 13:59 GMT-02:00 Romain Manni-Bucau <
> >>> rmannibucau@tomitribe.com>:
> >>> >
> >>> >> Hi
> >>> >>
> >>> >> yes you need a normal installation of activemq console + depending
> >>> >> what you use few more jars. Then the url is the webapp one (depend
> how
> >>> >> you deploy it)
> >>> >> Romain Manni-Bucau
> >>> >> Twitter: @rmannibucau
> >>> >> Blog: http://rmannibucau.wordpress.com/
> >>> >> LinkedIn: http://fr.linkedin.com/in/rmannibucau
> >>> >> Github: https://github.com/rmannibucau
> >>> >>
> >>> >>
> >>> >>
> >>> >> 2014-10-22 17:57 GMT+02:00 Felipe Jaekel <fkjaekel@gmail.com>:
> >>> >> > Hi,
> >>> >> >
> >>> >> > I saw Romain's post about ActiveMQ web console (
> http://goo.gl/JmyaXi
> >>> ),
> >>> >> but
> >>> >> > I didn't figured out if I need to install something else and
what
> is
> >>> the
> >>> >> > url to access on the browser.
> >>> >> >
> >>> >> > Thanks
> >>> >>
> >>>
> >>
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message