tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Gallimore <jonathan.gallim...@gmail.com>
Subject Re: Need advise on migration of EJB 2.x to EJB 3.x
Date Thu, 26 Feb 2015 13:03:03 GMT
We have a (now quite old) Eclipse plugin that could assist with this. Its
not compatible with the latest versions of Eclipse. I had an old alpha
build here:
http://people.apache.org/~jgallimore/test3/openejb-eclipse-plugins-1.0.0.alpha-src.zip
and video showing the install into Eclipse Ganymede here:
https://vimeo.com/7393498. The video also covers the OpenEJB WTP
functionality which you can ignore - the install is the first 3 minutes of
the video. You will most likely need an older version of Eclipse, such as
Ganymede, I doubt newer versions will work.

There are some instructions for the migration here:
http://openejb.apache.org/generating-ejb-3-annotations.html.

It would be good to update the plugins for the latest Eclipse versions and
create a release if they are useful. Any feedback would be most welcome -
please do let us know how you get on - good or bad. If you're interested in
hacking on any of the code for the plugins, I'd be happy to guide you.

Regards

Jon

On Thu, Feb 26, 2015 at 3:31 AM, Kodela Jagadish <k.jagdishchandra@gmail.com
> wrote:

> Hi,
>
>
> Could you please give your valuable advise on how to migrate from EJB 2.x
> to EJB 3.x.
>
> i am actually looking for any tool or any plugin to migrate the project in
> an efficient way with minimum manual work.
>
> Thanks.
>
> Best Regards,
> Kodela Jagadish.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message