tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leonardo K. Shikida" <shik...@gmail.com>
Subject Re: exposing the embedded activemq to JMX
Date Fri, 11 Sep 2015 22:51:49 GMT
I don't think the problem is a firewall, I am running everything locally,
but thanks for the tip.

ActiveMQBrowser seems to be designed for a standalone AMQ deployment. It
also recommends java6 (I am using java7, but I was assuming it was
compatible, maybe it's not)

Gonna try some other things here.

Anyway, it would be nice to force tomcat to always expose JMX in a fixed
port (it would be easier to reconnect jconsole), but this is another
history...




[]

Leo

On Fri, Sep 11, 2015 at 7:43 PM, Romain Manni-Bucau <rmannibucau@gmail.com>
wrote:

> default jmx connector needs 2 ports, are you behind a firewall?  I would
> recommand you jmxmp if you are behind a firewall (
>
> https://rmannibucau.wordpress.com/2014/04/22/tomee-makes-jmxmp-usage-simple/
> ).
>
> Side note: don't mix AMQ exposing JMX information (= publishing in JMX
> registry more or less) and being able to access JMX remotely using a
> connector (the system properties you added).
>
>
> Romain Manni-Bucau
> @rmannibucau <https://twitter.com/rmannibucau> |  Blog
> <http://rmannibucau.wordpress.com> | Github <
> https://github.com/rmannibucau> |
> LinkedIn <https://www.linkedin.com/in/rmannibucau> | Tomitriber
> <http://www.tomitribe.com>
>
> 2015-09-11 15:40 GMT-07:00 Leonardo K. Shikida <shikida@gmail.com>:
>
> > actually, it does not seem to work.
> >
> > I've also tried to set in catalina.sh
> >
> > CATALINA_OPTS=-Dcom.sun.management.jmxremote
> > -Dcom.sun.management.jmxremote.port=10099
> > -Dcom.sun.management.jmxremote.ssl=false
> > -Dcom.sun.management.jmxremote.authenticate=false
> >
> > but jconsole detects org.apache.catalina.startup.Bootstrap start at port
> > 11639 (some random port)
> >
> >
> > []
> >
> > Leo
> >
> > On Fri, Sep 11, 2015 at 5:48 PM, Romain Manni-Bucau <
> rmannibucau@gmail.com
> > >
> > wrote:
> >
> > > Hi Leo,
> > >
> > > think so (http://tomee.apache.org/activemqresourceadapter-config.html
> ),
> > > doesnt it work?
> > >
> > >
> > > Romain Manni-Bucau
> > > @rmannibucau <https://twitter.com/rmannibucau> |  Blog
> > > <http://rmannibucau.wordpress.com> | Github <
> > > https://github.com/rmannibucau> |
> > > LinkedIn <https://www.linkedin.com/in/rmannibucau> | Tomitriber
> > > <http://www.tomitribe.com>
> > >
> > > 2015-09-11 13:41 GMT-07:00 Leonardo K. Shikida <shikida@gmail.com>:
> > >
> > > > Hi
> > > >
> > > > I am trying to use activeMQbrowser to monitor tomee's default jms
> > > provider
> > > >
> > > > do I expose it to jmx like this?
> > > >
> > > >     <Resource id="MyJmsResourceAdapter"
> type="ActiveMQResourceAdapter">
> > > >             BrokerXmlConfig =
> > broker:(tcp://localhost:61616)?useJmx=true
> > > >                     ServerUrl       =  vm://localhost
> > > >                         </Resource>
> > > >
> > > > if not, how is the right way to do so?
> > > >
> > > > TIA
> > > >
> > > > Leo
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message