tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: Tomee connection issue to Tibco EMS provider
Date Tue, 22 Sep 2015 23:19:07 GMT
Hi

which version of TibjmsInitialContextFactory do you use? old versions used
com.tibco.tibjms.naming.security_protocol as a simple flag to activate ssl
only (ie if there ssl was on)


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau> | Tomitriber
<http://www.tomitribe.com>

2015-09-22 11:34 GMT-07:00 tomee_user2015 <tanmaya.sahoo@citi.com>:

> IBM WAS is using tcp connection to connect EMS provider i.e
> tcp://abc-dev5555.xyz.pqr.net:5555 and it is able to connect successfully.
>
> However for the same setting in tomee.xml I am not able to connect to the
> EMS provider.
>
> <Resource id="ems" type="GenericJMSRA"
> provider="com.sun.genericra.GenericJMSRA:genericra">
>                   UserName abc
>                   Password user
>                   ProviderIntegrationMode jndi
>
> XAConnectionFactoryClassName=com.tibco.tibjms.TibjmsXAConnectionFactory
>
>
> XAQueueConnectionFactoryClassName=com.tibco.tibjms.TibjmsXAQueueConnectionFactory
>
>
> XATopicConnectionFactoryClassName=com.tibco.tibjms.TibjmsXATopicConnectionFactory
>                   TopicClassName=com.tibco.tibjms.TibjmsTopic
>                   QueueClassName=com.tibco.tibjms.TibjmsQueue
>                   JndiProperties
>
> java.naming.factory.url.pkgs=com.tibco.tibjms.naming,java.naming.factory.initial=com.tibco.tibjms.naming.TibjmsInitialContextFactory,java.naming.provider.url=tcp://
> abc-dev5555.xyz.pqr.net:5555,
> com.tibco.tibjms.naming.security_protocol=tcp,
> com.tibco.tibjms.ssl.auth_only=false,java.naming.security.principal=abc
> ,java.naming.security.credentials=user
>                   LogLevel severe
>   </Resource>
> The URL is same, But it is using SSL (Tomee.xml holds tcp:// URL, Ref
> snippet) URL i.e ssl://abc-dev5555.xyz.pqr.net:5555 for connection when
> the
> application is started using Tomee.
>
> We are using following tibco jars and generic jar to connect:
>
> jms, tibcrypt, tibemsd_sec, tibjms, tibjmsadmin, tibjmsapps, tibjmsufo,
> tibrvjms, genericra
>
>
>
> --
> View this message in context:
> http://tomee-openejb.979440.n4.nabble.com/Tomee-connection-issue-to-Tibco-EMS-provider-tp4676321.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message