tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roberto Cortez <radcor...@yahoo.com.INVALID>
Subject Re: Connector Resource Adapter Issues
Date Fri, 20 May 2016 00:14:24 GMT
And the issues:
https://issues.apache.org/jira/browse/TOMEE-1816

https://issues.apache.org/jira/browse/TOMEE-1817



      From: Roberto Cortez <radcortez@yahoo.com.INVALID>
 To: "users@tomee.apache.org" <users@tomee.apache.org> 
 Sent: Thursday, May 19, 2016 4:50 PM
 Subject: Connector Resource Adapter Issues
   
Hi,
I have been implementing a Connector Resource Adapter and run into some issues:
  
  -  If I add a property getter into a resourceadapter-class or into a managedconnectionfactory-class,
when deploying I get a NPE, since it expects the setter to be there. The deployed classes
are available, but configuration might not be loaded properly since the configuration load
is interrupted by the NPE. I had a look into the spec, and yes for config properties you are
required to have a getter / setter, but I couldn't find anything telling you that you can't
have a regular property with just a getter (it's just not configurable).

  
  - When using the configuration "validationInterval" to provide connection validation, the
connector just fails to deploy with a java.lang.NoSuchFieldException: pool

Did anyone else run into these issue?
In the meanwhile, I'm creating JIRA issue, plus tests. I would also like to fix these myself
if they confirm to be problems.
Cheers,Roberto

  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message