tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gilbertoca <gilbert...@gmail.com>
Subject Re: UTF-8 form submit in JSF is corrupting data - MyFaces issue
Date Thu, 09 Jun 2016 18:40:30 GMT
Romain Manni-Bucau wrote
> Hi
> 
> Tomcat supports setting encoding on the connector and provides a encoding
> filter IIRC which can solve it.

So, the tomee-embedded-maven-plugin Tomcat connector is not setup the same
way as in TomEE plume.
How can I adjust it in the tomee-embedded-maven-plugin? 


Romain Manni-Bucau wrote
> If not myfaceq list is the right place to ask.
> 
> Le 9 juin 2016 20:51, "gilbertoca" &lt;

> gilbertoca@

> &gt; a écrit :
> 
>>
>> Hi everyone!
>>
>> I have a problem with the values inserted in all my 
> <h:inputText>
>  fields.
>> Some characters are not encoded in the right way. E.g. if I put "ção" in
>> the
>> input field I get "ão" .
>> Using tomee-embedded-maven-plugin with default settings, I mean, MyFaces:
>>
>>
>>
>> After a day searching and changing a lot of configurations, I've decided
>> to
>> run the project with TomEE(plume) but with Mojarra and to my surprise no
>> encoding problem. I think it is a MyFaces issue, WDYT?
>> Do you think it deserves a post in the MyFaces user list?
>>
>> Regards,
>>
>> Gilberto
>>
>>
>>
>>
>> --
>> View this message in context:
>> http://tomee-openejb.979440.n4.nabble.com/UTF-8-form-submit-in-JSF-is-corrupting-data-MyFaces-issue-tp4678824.html
>> Sent from the TomEE Users mailing list archive at Nabble.com.
>>





--
View this message in context: http://tomee-openejb.979440.n4.nabble.com/UTF-8-form-submit-in-JSF-is-corrupting-data-MyFaces-issue-tp4678824p4678828.html
Sent from the TomEE Users mailing list archive at Nabble.com.

Mime
View raw message