tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: TomEE 7: problem with @WebXXX annotations
Date Mon, 13 Jun 2016 14:13:45 GMT
Ok I see, can reproduced, created
https://issues.apache.org/jira/browse/TOMEE-1841 and should be fixed today


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<https://blog-rmannibucau.rhcloud.com> | Old Wordpress Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau> | Tomitriber
<http://www.tomitribe.com> | JavaEE Factory
<https://javaeefactory-rmannibucau.rhcloud.com>

2016-06-13 15:53 GMT+02:00 Felipe Jaekel <fkjaekel@gmail.com>:

> Hi,
>
> Sorry the issue is with parallel deployment. Same app works fine when
> parallel deployed on 1.7.2. I mentioned the symlink issue in case it's
> relevant.
>
> gitbub source:
> https://github.com/fkjaekel/mavenproject
> https://github.com/fkjaekel/UtilModule
>
> To reproduce it I just copy the war file on the webapp folder and open
> http://localhost:8080/mavenproject on the browser. The output is *Test
> string: listener not initialized*. If I rename the war and remove the
> version the output is *Test string: listener initialized.*
>
> I think I can reproduce it with Arquillian if necessary.
>
> Thanks
>
> 2016-06-13 9:22 GMT-03:00 Romain Manni-Bucau <rmannibucau@gmail.com>:
>
> > Hi
> >
> > the code for tomee 1 and 7 is the same for that so if it works on 1.7.4
> it
> > should work on 7.0.
> >
> > Is your issue linked to parallel deployment or sym links - AFAIK symlink
> > issue should be solved?
> >
> > Side note: when sharing sources can you do it on a public repo (like
> > github/bitbucket)?
> >
> > Also what are the steps to reproduce it? ANy way to add a testcase to the
> > project - using arquillian for instance - to let us reproduce it the same
> > way you see it?
> >
> >
> >
> > Romain Manni-Bucau
> > @rmannibucau <https://twitter.com/rmannibucau> |  Blog
> > <https://blog-rmannibucau.rhcloud.com> | Old Wordpress Blog
> > <http://rmannibucau.wordpress.com> | Github <
> > https://github.com/rmannibucau> |
> > LinkedIn <https://www.linkedin.com/in/rmannibucau> | Tomitriber
> > <http://www.tomitribe.com> | JavaEE Factory
> > <https://javaeefactory-rmannibucau.rhcloud.com>
> >
> > 2016-06-13 14:13 GMT+02:00 Felipe Jaekel <fkjaekel@gmail.com>:
> >
> > > Hi,
> > >
> > > When I parallel deploy a webapp on TomEE 7, @WebXXX annotations are
> > > ignored.
> > >
> > > It's the same issue I had when I tried to use TomEE 1.7.1 with symbolic
> > > links.
> > >
> > > Do I need additional config for TomEE 7?
> > >
> > > Thanks
> > >
> > >
> > > *Reference:*
> > > https://issues.apache.org/jira/browse/TOMEE-1370
> > >
> > >
> >
> https://qnalist.com/questions/5172279/listeners-annotated-outside-webapp-are-ignored
> > >
> > > *Sample:*
> > > WAR: https://db.tt/XKqMXIw2
> > > Source: https://db.tt/f8xUnBDg
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message