tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: Unable to deploy web application in TomEEPlume1.7.3. It works with Tomcat7.0.47
Date Mon, 20 Jun 2016 06:31:34 GMT
likely cause the persistence.xml is scanned and the provider not set in
persistence.xml. If it is resource_local and doesnt need container handling
(no @PersistenceUnit for instance) then just exclude the jar


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<https://blog-rmannibucau.rhcloud.com> | Old Wordpress Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau> | Tomitriber
<http://www.tomitribe.com> | JavaEE Factory
<https://javaeefactory-rmannibucau.rhcloud.com>

2016-06-20 7:48 GMT+02:00 sundar <esakkisundar.v@tcs.com>:

> Hi Romain,
>         We are using Hibernate. We dont have the EclipseLink related jars
> in my project structure as well. How to avoid EclipseLink getting kicking
> in?
>
> Regards,
> Sundar.
>
> -----"Romain Manni-Bucau [via TomEE & OpenEJB]" <
> ml-node+s979440n4678964h87@n4.nabble.com> wrote: -----
> To: sundar <esakkisundar.v@tcs.com>
> From: "Romain Manni-Bucau [via TomEE & OpenEJB]" <
> ml-node+s979440n4678964h87@n4.nabble.com>
> Date: 06/20/2016 11:42AM
> Subject: Re: Unable to deploy web application in TomEEPlume1.7.3. It works
> with Tomcat7.0.47
>
> Well, tomee will do more than tomact at startup and then it depends your
> app. If you don't need this part then just exclude the jars containing
> these classes with exclusions.list.
>
> About the error: it seems hibernate and openjpa tolerates a mapping of date
> more largely than eclipselink which implements strictly one sentence of the
> spec (we got the same issue on batchee). Said otherwise it would need to be
> fixed on drools or you need to not use eclipselink for these entities to
> get rid of it.
>
>
>
> Romain Manni-Bucau
> @rmannibucau <https://twitter.com/rmannibucau> |  Blog
> <https://blog-rmannibucau.rhcloud.com> | Old Wordpress Blog
> <http://rmannibucau.wordpress.com> | Github <
> https://github.com/rmannibucau> |
> LinkedIn <https://www.linkedin.com/in/rmannibucau> | Tomitriber
> <http://www.tomitribe.com> | JavaEE Factory
> <https://javaeefactory-rmannibucau.rhcloud.com>
>
> 2016-06-20 6:46 GMT+02:00 sundar <[hidden email]>:
>
> > Hi Romain,
> >         I tried to add all the necessary jars (which tomee was
> > complaining) to my web application. As I mentioned I never had to add
> these
> > jars to work in Tomcat. Now when I start my application, I get the
> attached
> > error and I don't have any control over changing these entities. Please
> > suggest what could be done.
> >
> > Regards,
> > Sundar.
> >
> > -----"Romain Manni-Bucau [via TomEE & OpenEJB]" <
> > [hidden email]> wrote: -----
> > To: sundar <[hidden email]>
> > From: "Romain Manni-Bucau [via TomEE & OpenEJB]" <
> > [hidden email]>
> > Date: 06/17/2016 02:35PM
> > Subject: Re: Unable to deploy web application in TomEEPlume1.7.3. It
> works
> > with Tomcat7.0.47
> >
> > Just configure the scanning to exclude jars referring to this missing
> > class.
> > Le 17 juin 2016 10:28, "sundar" <[hidden email]> a écrit :
> >
> > > Hi Romain,
> > >         Sorry. Could you please explain in detail what you would like
> me
> > > to do. It will really help me as I'm struggling to sort this issue out.
> > >
> > > Regards,
> > > Sundar.
> > >
> > > -----"Romain Manni-Bucau [via TomEE & OpenEJB]" <
> > > [hidden email]> wrote: -----
> > > To: sundar <[hidden email]>
> > > From: "Romain Manni-Bucau [via TomEE & OpenEJB]" <
> > > [hidden email]>
> > > Date: 06/17/2016 12:17PM
> > > Subject: Re: Unable to deploy web application in TomEEPlume1.7.3. It
> > works
> > > with Tomcat7.0.47
> > >
> > > Ok so likely a jar scanned with a dependency on that CommandWebService
> > > which is missing. Add a WEB-INF/exclusions.list with
> > >
> > > default-list
> > > [all jar prefix you dont need to scan]
> > >
> > > for instance
> > >
> > > default-list
> > > spring
> > > drools
> > > ...
> > >
> > >
> > > Romain Manni-Bucau
> > > @rmannibucau <https://twitter.com/rmannibucau> |  Blog
> > > <https://blog-rmannibucau.rhcloud.com> | Old Wordpress Blog
> > > <http://rmannibucau.wordpress.com> | Github <
> > > https://github.com/rmannibucau> |
> > > LinkedIn <https://www.linkedin.com/in/rmannibucau> | Tomitriber
> > > <http://www.tomitribe.com> | JavaEE Factory
> > > <https://javaeefactory-rmannibucau.rhcloud.com>
> > >
> > > 2016-06-17 7:53 GMT+02:00 sundar <[hidden email]>:
> > >
> > > > Hi Romain,
> > > >    Pl find attached list of jars used in the application.  jar.txt
> > > > <http://tomee-openejb.979440.n4.nabble.com/file/n4678942/jar.txt>
>  . I
> > > > have
> > > > also added kie-remote-ws-wsdl-cmd-6.1.0.Beta4 to my
> > > > apache-tomee-plume-1.7.3\lib folder. However while starting the
> > > application
> > > > getting the below error. Please help.
> > > >
> > > > org.apache.catalina.LifecycleException: Failed to start component
> > > > [StandardEngine[Catalina].StandardHost[localhost].StandardContext[
> > > >         at
> > > > org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
> > > >         at
> > > >
> > > >
> > >
> >
> org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
> > > >         at
> > > >
> org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
> > > >         at
> > > > org.apache.catalina.core.StandardHost.addChild(StandardHost.java:652)
> > > >         at
> > > >
> org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:1095)
> > > >         at
> > > >
> > >
> >
> org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1930)
> > > >         at
> > > >
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
> > > >         at java.util.concurrent.FutureTask.run(FutureTask.java:262)
> > > >         at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
> > > >         at
> > > >
> > > >
> > >
> >
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> > > >         at java.lang.Thread.run(Thread.java:744)
> > > > Caused by: java.lang.NoClassDefFoundError:
> > > > org/kie/remote/services/ws/wsdl/generated/CommandWebService
> > > >         at java.lang.ClassLoader.defineClass1(Native Method)
> > > >         at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
> > > > ÿ ÿ ÿ ÿ at
> > > >
> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
> > > > ÿ ÿ ÿ ÿ at
> java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
> > > > ÿ ÿ ÿ ÿ at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
> > > > ÿ ÿ ÿ ÿ at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
> > > > ÿ ÿ ÿ ÿ at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
> > > >
> > > >
> > > >
> > > > --
> > > > View this message in context:
> > > >
> > >
> >
> http://tomee-openejb.979440.n4.nabble.com/Unable-to-deploy-web-application-in-TomEEPlume1-7-3-It-works-with-Tomcat7-0-47-tp4678842p4678942.html
> > > > Sent from the TomEE Users mailing list archive at Nabble.com.
> > > >
> > >
> > >
> > > If you reply to this email, your message will be added to the
> discussion
> > > below:
> > >
> > >
> >
> http://tomee-openejb.979440.n4.nabble.com/Unable-to-deploy-web-application-in-TomEEPlume1-7-3-It-works-with-Tomcat7-0-47-tp4678842p4678943.html
> > > To unsubscribe from Unable to deploy web application in
> TomEEPlume1.7.3.
> > > It works with Tomcat7.0.47, click here.
> > > NAML
> > > =====-----=====-----=====
> > > Notice: The information contained in this e-mail
> > > message and/or attachments to it may contain
> > > confidential or privileged information. If you are
> > > not the intended recipient, any dissemination, use,
> > > review, distribution, printing or copying of the
> > > information contained in this e-mail message
> > > and/or attachments to it are strictly prohibited. If
> > > you have received this communication in error,
> > > please notify us by reply e-mail or telephone and
> > > immediately and permanently delete the message
> > > and any attachments. Thank you
> > >
> > >
> > >
> > >
> > >
> > >
> > > --
> > > View this message in context:
> > >
> >
> http://tomee-openejb.979440.n4.nabble.com/Unable-to-deploy-web-application-in-TomEEPlume1-7-3-It-works-with-Tomcat7-0-47-tp4678842p4678944.html
> > > Sent from the TomEE Users mailing list archive at Nabble.com.
> >
> >
> > If you reply to this email, your message will be added to the discussion
> > below:
> >
> >
> http://tomee-openejb.979440.n4.nabble.com/Unable-to-deploy-web-application-in-TomEEPlume1-7-3-It-works-with-Tomcat7-0-47-tp4678842p4678945.html
> > To unsubscribe from Unable to deploy web application in TomEEPlume1.7.3.
> > It works with Tomcat7.0.47, click here.
> > NAML
> >
> > Exception.txt (3K) <
> >
> http://tomee-openejb.979440.n4.nabble.com/attachment/4678963/0/Exception.txt
> > >
> >
> >
> >
> >
> > --
> > View this message in context:
> >
> http://tomee-openejb.979440.n4.nabble.com/Unable-to-deploy-web-application-in-TomEEPlume1-7-3-It-works-with-Tomcat7-0-47-tp4678842p4678963.html
> > Sent from the TomEE Users mailing list archive at Nabble.com.
> >
>
>
> If you reply to this email, your message will be added to the discussion
> below:
>
> http://tomee-openejb.979440.n4.nabble.com/Unable-to-deploy-web-application-in-TomEEPlume1-7-3-It-works-with-Tomcat7-0-47-tp4678842p4678964.html
> To unsubscribe from Unable to deploy web application in TomEEPlume1.7.3.
> It works with Tomcat7.0.47, click here.
> NAML
>
>
>
> --
> View this message in context:
> http://tomee-openejb.979440.n4.nabble.com/Unable-to-deploy-web-application-in-TomEEPlume1-7-3-It-works-with-Tomcat7-0-47-tp4678842p4678966.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message