tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: tomee 7.0.0 and deltaspike
Date Wed, 01 Jun 2016 07:56:24 GMT
Yes, DS pom is quite complex and we don't handle yet tomee 7 properly I
think


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau> | Tomitriber
<http://www.tomitribe.com> | JavaEE Factory
<https://javaeefactory-rmannibucau.rhcloud.com>

2016-06-01 9:14 GMT+02:00 hwaastad <helge@waastad.org>:

> Hi,
> just an observation (and maybe somthing for ds), but by using
> <dependency>
>                 <groupId>org.apache.deltaspike.distribution</groupId>
>                 <artifactId>distributions-bom</artifactId>
>                 <version>${ds.version}</version>
>                 <type>pom</type>
>                 <scope>import</scope>
>             </dependency>
>
> i deps management for tomee 7.0.0:
> and running appcomposer test:
>
> OpenEJBException: Creating application failed:
> /home/helge/whatever/GetTokenIT:
> org/apache/webbeans/spi/BeanArchiveService$BeanArchiveInformation
> Caused by: java.lang.NoClassDefFoundError:
> org/apache/webbeans/spi/BeanArchiveService$BeanArchiveInformation
> Caused by: java.lang.ClassNotFoundException:
> org.apache.webbeans.spi.BeanArchiveService$BeanArchiveInformation
>
> excluding import dep, all is well.
>
> Is this something ds needs to fix?
>
> /hw
>
>
>
> --
> View this message in context:
> http://tomee-openejb.979440.n4.nabble.com/tomee-7-0-0-and-deltaspike-tp4678704.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message