tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sundar <esakkisunda...@tcs.com>
Subject Re: Unable to deploy web application in TomEEPlume1.7.3. It works with Tomcat7.0.47
Date Mon, 13 Jun 2016 06:45:52 GMT
Hi Romain,
	I used Tomee1.7.3 and Tomee7.0.0. In both servers application is not getting deployed. I
have packaged all the necessary jars needed for my application into WEB-INF\lib folder. I
have used what ever server config came with the installation and did not touched any server
configs.

Regards,
Sundar.

-----"Romain Manni-Bucau [via TomEE & OpenEJB]" <ml-node+s979440n4678843h36@n4.nabble.com>
wrote: -----
To: sundar <esakkisundar.v@tcs.com>
From: "Romain Manni-Bucau [via TomEE & OpenEJB]" <ml-node+s979440n4678843h36@n4.nabble.com>
Date: 06/10/2016 06:47PM
Subject: Re: Unable to deploy web application in TomEEPlume1.7.3. It works with Tomcat7.0.47

Hi 

did you try on 1.7.4 or 7.0.0? 

What's your server config? 

What do you deploy as libraries? 


Romain Manni-Bucau 
@rmannibucau <https://twitter.com/rmannibucau> |  Blog 
<https://blog-rmannibucau.rhcloud.com> | Old Wordpress Blog 
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |

LinkedIn <https://www.linkedin.com/in/rmannibucau> | Tomitriber 
<http://www.tomitribe.com> | JavaEE Factory 
<https://javaeefactory-rmannibucau.rhcloud.com> 

2016-06-10 13:48 GMT+02:00 sundar <[hidden email]>: 

> Hi, 
>     Im trying to deploy a war file to apache-tomee-plume-1.7.3. While 
> starting the application I'm getting the below error. I've added the jar 
> file to apache-tomee-plume-1.7.3\lib and in the application WEB-INF\lib 
> folder as well. 
>     However if I install the application even without this jar to 
> Tomcat7.0.47 it works fine without any issues. Please suggest how to 
> resolve 
> this issue with apache-tomee-plume-1.7.3. 
> 
> Jun 10, 2016 12:32:20 PM org.apache.catalina.core.ContainerBase 
> addChildInternal 
> SEVERE: ContainerBase.addChild: start: 
> org.apache.catalina.LifecycleException: Failed to start component 
> [StandardEngine[Catalina].StandardHost[localhost].StandardContext 
>         at 
> org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154) 
>         at 
> 
> org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901) 
>         at 
> org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877) 
>         at 
> org.apache.catalina.core.StandardHost.addChild(StandardHost.java:652) 
>         at 
> 
> org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1263) 
>         at 
> 
> org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1948) 
>         at 
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) 
>         at java.util.concurrent.FutureTask.run(FutureTask.java:262) 
>         at 
> 
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) 
>         at 
> 
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) 
>         at java.lang.Thread.run(Thread.java:744) 
> Caused by: java.lang.NoClassDefFoundError: 
> org/kie/remote/services/ws/wsdl/generated/CommandWebService 
>         at java.lang.ClassLoader.defineClass1(Native Method) 
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:800) 
>         at 
> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) 
>         at java.net.URLClassLoader.defineClass(URLClassLoader.java:449) 
>         at java.net.URLClassLoader.access$100(URLClassLoader.java:71) 
> 
> 
> 
> -- 
> View this message in context: 
> http://tomee-openejb.979440.n4.nabble.com/Unable-to-deploy-web-application-in-TomEEPlume1-7-3-It-works-with-Tomcat7-0-47-tp4678842.html
> Sent from the TomEE Users mailing list archive at Nabble.com. 
> 


If you reply to this email, your message will be added to the discussion below:
http://tomee-openejb.979440.n4.nabble.com/Unable-to-deploy-web-application-in-TomEEPlume1-7-3-It-works-with-Tomcat7-0-47-tp4678842p4678843.html
To unsubscribe from Unable to deploy web application in TomEEPlume1.7.3. It works with Tomcat7.0.47,
click here.
NAML
=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you






--
View this message in context: http://tomee-openejb.979440.n4.nabble.com/Unable-to-deploy-web-application-in-TomEEPlume1-7-3-It-works-with-Tomcat7-0-47-tp4678842p4678857.html
Sent from the TomEE Users mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message