tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From marcel ...@marcelruff.info>
Subject JPA2.1 usage with openEJB in Java SE environment
Date Tue, 09 Aug 2016 10:12:33 GMT
Hi,need to run the openEJB (EJB 3.2 JSR 345) container with hibernate 5.2.1
(JPA 2.1 JSR 338) in a Java SE 8 environment with 
/javax.ejb.embeddable.EJBContainer.createEJBContainer();/Using openEJB 4.7.4
directly with maven /org.apache.openejb  openejb-core  4.7.4/runs fine with
a persistence.xml JPA "*2.0*"  //but fails with a persistence.xml JPA
"*2.1*"  //with a SAX parser error.Downloading
apache-tomee-7.0.1-plume.tar.gz and adding all  
/apache-tomee-plume-7.0.1/lib/*.jar/to CLASSPATH fixes this and I can use
JPA 2.1!1) Can somebody shed some light on why openEJB natively does not
support JPA-2.1 but inside TomEE does run fine?2) Is there a maven
repository for openEJB jars with JPA-2.1 support to avoid too many
jars?thank youMarcel



--
View this message in context: http://tomee-openejb.979440.n4.nabble.com/JPA2-1-usage-with-openEJB-in-Java-SE-environment-tp4679678.html
Sent from the TomEE Users mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message