tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vnalla <v_na...@hotmail.com>
Subject Re: TomEE 7.0.1 Arquillian Test deployment error with remote adaptor
Date Wed, 31 Aug 2016 23:21:22 GMT
Hi,

It is working when the following properties are set as shown below:

tomee.serialization.class.blacklist = -
tomee.serialization.class.whitelist = *
which is allowing everything from my understanding and as good as not having
this feature at all. When I tried to set a particular class, in this do not
know what to set for remote deployment and it has been trial and error. So
far I have set it to following:
tomee.serialization.class.whitelist =
java.lang.String,org.apache.openejb.core.,java.lang.Exception,java.lang.RuntimeException,java.lang.SecurityException,org.apache.openejb.assembler.Deployer,org.apache.openejb.BeanContext\$BusinessRemoteHome,java.net.URI,\[Ljava.net.URI\;
and still getting an error and it is asking me to set java.lang.Properties.
Does this need to be trial and error method to set the whitelist classes?
and How many classes? is it all the classes in the inheritance hierarchy -
it does not look like though.

How do make "TomEE GUI" button to work? I am getting 404 error.

Thanks a lot for your time and help.

-Venkat




--
View this message in context: http://tomee-openejb.979440.n4.nabble.com/TomEE-7-0-1-Arquillian-Test-deployment-error-with-remote-adaptor-tp4679986p4679992.html
Sent from the TomEE Users mailing list archive at Nabble.com.

Mime
View raw message