tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KARR, DAVID" <dk0...@att.com>
Subject Confused why other user is failing to find Oracle driver in classpath
Date Tue, 16 Aug 2016 18:27:42 GMT
My app is running fine on my laptop, using TomEE 7.0.1.  I'm trying to set up another person
to run the same service on his laptop.  I had him install the same JDK, TomEE, and Eclipse.
 I had him use the same server config files that I'm using.  We specify to load the Oracle
driver with the 'classpath="mvn:..." strategy in the DataSource definition.

When he starts his server, he sees the following stacktrace:
-------------------
Aug 16, 2016 11:21:28 AM org.apache.openejb.util.OpenEJBErrorHandler handleUnknownError
SEVERE: FATAL ERROR: Unknown error in Assembler.  Please send the following stack trace and
this message to users@tomee.apache.org :
org.apache.xbean.propertyeditor.PropertyEditorException: Unable to resolve class oracle.jdbc.driver.OracleDriver
       at org.apache.xbean.propertyeditor.ClassEditor.toObjectImpl(ClassEditor.java:43)
       at org.apache.xbean.propertyeditor.AbstractConverter.toObject(AbstractConverter.java:86)
       at org.apache.xbean.propertyeditor.PropertyEditors.getValue(PropertyEditors.java:284)
       at org.apache.xbean.recipe.RecipeHelper.convert(RecipeHelper.java:181)
       at org.apache.xbean.recipe.ObjectRecipe.extractConstructorArgs(ObjectRecipe.java:592)
       at org.apache.xbean.recipe.ObjectRecipe.internalCreate(ObjectRecipe.java:275)
       at org.apache.xbean.recipe.AbstractRecipe.create(AbstractRecipe.java:96)
       at org.apache.xbean.recipe.AbstractRecipe.create(AbstractRecipe.java:61)
       at org.apache.openejb.assembler.classic.Assembler.doCreateResource(Assembler.java:2965)
       at org.apache.openejb.assembler.classic.Assembler.createResource(Assembler.java:2800)
       at org.apache.openejb.assembler.classic.Assembler.buildContainerSystem(Assembler.java:574)
       at org.apache.openejb.assembler.classic.Assembler.build(Assembler.java:483)
       at org.apache.openejb.OpenEJB$Instance.<init>(OpenEJB.java:150)
       at org.apache.openejb.OpenEJB.init(OpenEJB.java:307)
       at org.apache.tomee.catalina.TomcatLoader.initialize(TomcatLoader.java:247)
       at org.apache.tomee.catalina.ServerListener.lifecycleEvent(ServerListener.java:168)
       at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:94)
       at org.apache.catalina.util.LifecycleBase.setStateInternal(LifecycleBase.java:401)
       at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:115)
       at org.apache.catalina.startup.Catalina.load(Catalina.java:606)
       at org.apache.catalina.startup.Catalina.load(Catalina.java:629)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
       at java.lang.reflect.Method.invoke(Method.java:498)
       at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:311)
       at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:494)
Caused by: java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver
       at org.apache.openejb.util.classloader.URLClassLoaderFirst.loadClass(URLClassLoaderFirst.java:140)
       at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
       at java.lang.Class.forName0(Native Method)
       at java.lang.Class.forName(Class.java:348)
       at org.apache.xbean.propertyeditor.ClassEditor.toObjectImpl(ClassEditor.java:40)
       ... 26 more
-------------------------

I've looked at his .m2/repository, and the correct jar file is there, and it has the specified
class.  What could he possibly have done differently in his setup compared to mine?

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message