tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jlemoine <jlemo...@bcidaho.com>
Subject Re: HTTP Errors on Load-Balanced TomEE Servers
Date Mon, 03 Oct 2016 12:44:08 GMT
Romain Manni-Bucau wrote
> Hi
> 
> it would be interesting to tune the timeouts on the connector(s) -
> potentially on the LB too.
> 
> If it happens again don't forget to take a thread dump of processes, it
> often helps to see what the server is doing and if it is just busy.
> 
> 
> 
> Romain Manni-Bucau
> @rmannibucau &lt;https://twitter.com/rmannibucau&gt; |  Blog
> &lt;https://blog-rmannibucau.rhcloud.com&gt; | Old Wordpress Blog
> &lt;http://rmannibucau.wordpress.com&gt; | Github
> &lt;https://github.com/rmannibucau&gt; |
> LinkedIn &lt;https://www.linkedin.com/in/rmannibucau&gt; | Tomitriber
> &lt;http://www.tomitribe.com&gt; | JavaEE Factory
> &lt;https://javaeefactory-rmannibucau.rhcloud.com&gt;
> 
> 2016-09-29 21:25 GMT+02:00 Jlemoine &lt;

> jlemoine@

> &gt;:
> 
>>
>>
>> --
>> View this message in context: http://tomee-openejb.979440.
>> n4.nabble.com/HTTP-Errors-on-Load-Balanced-TomEE-Servers-tp4680255.html
>> Sent from the TomEE Users mailing list archive at Nabble.com.
>>

Thanks Romain.  I have been working on testing the connector timeouts,
although I haven't seen any performance improvements yet in my test
environment.
I can't mirror the same load in test as in prod but by throwing thousands of
sim users at the web servers I can create the same symptoms.  Doing a thread
dump with VisualVM does seem to comfirm what I suspected... a socket issue
with the ajp connectors.



--
View this message in context: http://tomee-openejb.979440.n4.nabble.com/HTTP-Errors-on-Load-Balanced-TomEE-Servers-tp4680255p4680270.html
Sent from the TomEE Users mailing list archive at Nabble.com.

Mime
View raw message