tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hwaastad <he...@waastad.org>
Subject Re: cxf interceptors in 2.0 api
Date Mon, 17 Oct 2016 12:28:30 GMT
BTW,
not sure if this is a cxf or tomee issue, but I've noticed something
strange.

I'm invoking an async client and if I register the loggingfeature it prints
out two response, one with payload, the other without.

Like this:
ID: 1
Address: https://myapi/service
Http-Method: POST
Content-Type: application/json
Headers: {Accept=[application/json], Content-Type=[application/json]}
Payload: {"u_name":"3560c","u_produktid":"strv-12345","u_sh_desc":"3560
svitsj
bla","u_model_cat":"bceb7454c3031000b959fd251eba8f42","u_manufacturer":"9abf0bf27139f400234e531439ad1ea0"}
--------------------------------------
okt 17, 2016 2:21:49 PM org.apache.cxf.interceptor.LoggingInInterceptor
INFO: Inbound Message
----------------------------
ID: 1
Response-Code: 401
Encoding: UTF-8
Content-Type: application/json;charset=UTF-8
Headers: {Cache-control=[no-cache,no-store,must-revalidate,max-age=-1],
connection=[close], content-type=[application/json;charset=UTF-8],
Date=[Mon, 17 Oct 2016 12:21:48 GMT], Expires=[0],
Pragma=[no-store,no-cache], Server=[SN],
Set-Cookie=[BIGipServerpool_myip=562090506.37438.0000; path=/,
JSESSIONID=E83C9FEA995F803ABCC8E0215F06E36A;Secure; Path=/; HttpOnly],
Strict-Transport-Security=[max-age=15768000; includeSubDomains;],
transfer-encoding=[chunked], WWW-Authenticate=[BASIC realm="SN"]}
Payload: {"error":{"message":"User Not Authenticated","detail":"Required to
provide Auth information"},"status":"failure"}
--------------------------------------
okt 17, 2016 2:21:49 PM org.apache.cxf.interceptor.LoggingInInterceptor
INFO: Inbound Message
----------------------------
ID: 1
Response-Code: 401
Encoding: UTF-8
Content-Type: application/json;charset=UTF-8
Headers: {Cache-control=[no-cache,no-store,must-revalidate,max-age=-1],
connection=[close], content-type=[application/json;charset=UTF-8],
Date=[Mon, 17 Oct 2016 12:21:48 GMT], Expires=[0],
Pragma=[no-store,no-cache], Server=[SN],
Set-Cookie=[BIGipServerpool_myapi=562090506.37438.0000; path=/,
JSESSIONID=E83C9FEA995F803ABCC8E0215F06E36A;Secure; Path=/; HttpOnly],
Strict-Transport-Security=[max-age=15768000; includeSubDomains;],
transfer-encoding=[chunked], WWW-Authenticate=[BASIC realm="SN"]}
--------------------------------------

So consuming entity will return zero.

Seen this before?

/hw



--
View this message in context: http://tomee-openejb.979440.n4.nabble.com/cxf-interceptors-in-2-0-api-tp4680333p4680336.html
Sent from the TomEE Users mailing list archive at Nabble.com.

Mime
View raw message