tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: deltaspike 1.7.2 not working with tomee 1.7.2 plus
Date Tue, 08 Nov 2016 10:21:41 GMT
Hi Mauro,

first you should try on 1.7.4 (1.7.2 will not get support). That said it
looks like you can miss the an impl module.


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<https://blog-rmannibucau.rhcloud.com> | Old Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau> | JavaEE Factory
<https://javaeefactory-rmannibucau.rhcloud.com>

2016-11-08 11:08 GMT+01:00 mauro2java2011 <mauro2java2011@gmail.com>:

> hi. i have tried deltaspike 1.7.2 with tomee 1.7.2 plus
> it not working .
> go at paste bin
> http://pastebin.com/hBShW2PS
>
>
> i think that is a error for :
>
> Caused by: java.util.ServiceConfigurationError:
> javax.enterprise.inject.spi.Extension: Provider
> org.apache.deltaspike.jsf.impl.injection.proxy.
> ConverterAndValidatorProxyExtension
> could not be instantiated
>     at java.util.ServiceLoader.fail(ServiceLoader.java:232)
>     at java.util.ServiceLoader.access$100(ServiceLoader.java:185)
>     at
> java.util.ServiceLoader$LazyIterator.nextService(ServiceLoader.java:384)
>     at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:404)
>     at java.util.ServiceLoader$1.next(ServiceLoader.java:480)
>     at
> org.apache.webbeans.service.DefaultLoaderService.load(
> DefaultLoaderService.java:54)
>     at
> org.apache.openejb.cdi.OptimizedLoaderService.loadExtensions(
> OptimizedLoaderService.java:72)
>     at
> org.apache.openejb.cdi.OptimizedLoaderService.load(
> OptimizedLoaderService.java:66)
>     at
> org.apache.webbeans.portable.events.ExtensionLoader.loadExtensionServices(
> ExtensionLoader.java:77)
>     at
> org.apache.webbeans.portable.events.ExtensionLoader.loadExtensionServices(
> ExtensionLoader.java:68)
>     at
> org.apache.webbeans.config.BeansDeployer.deploy(BeansDeployer.java:158)
>     at
> org.apache.openejb.cdi.OpenEJBLifecycle.startApplication(
> OpenEJBLifecycle.java:192)
>     at
> org.apache.openejb.cdi.ThreadSingletonServiceImpl.initialize(
> ThreadSingletonServiceImpl.java:160)
>     at org.apache.openejb.cdi.CdiBuilder.build(CdiBuilder.java:41)
>     at
> org.apache.openejb.assembler.classic.Assembler.
> createApplication(Assembler.java:846)
>     ... 50 more
> Caused by: java.lang.NoClassDefFoundError:
> org/apache/deltaspike/proxy/api/DeltaSpikeProxyFactory
>     at java.lang.Class.getDeclaredConstructors0(Native Method)
>     at java.lang.Class.privateGetDeclaredConstructors(Class.java:2671)
>     at java.lang.Class.getConstructor0(Class.java:3075)
>     at java.lang.Class.newInstance(Class.java:412)
>     at
> java.util.ServiceLoader$LazyIterator.nextService(ServiceLoader.java:380)
>     ... 62 more
> Caused by: java.lang.ClassNotFoundException:
> org.apache.deltaspike.proxy.api.DeltaSpikeProxyFactory
>     at
> org.apache.catalina.loader.WebappClassLoader.loadClass(
> WebappClassLoader.java:1720)
>     at
> org.apache.tomee.catalina.LazyStopWebappClassLoader.loadClass(
> LazyStopWebappClassLoader.java:171)
>     at
> org.apache.catalina.loader.WebappClassLoader.loadClass(
> WebappClassLoader.java:1571)
>     ... 67 more
>
>
> --------------------------------
>
> i have to add also the proxy module of deltaspike 1.7.2 at web-inf/lib?
>
>
>
>
> --
> View this message in context: http://tomee-openejb.979440.
> n4.nabble.com/deltaspike-1-7-2-not-working-with-tomee-1-7-
> 2-plus-tp4680493.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message