tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keerati Jittrawong <keer...@inventus.co.th>
Subject Feedback on TomEE 7.0.2 - SSL stability problem
Date Tue, 20 Dec 2016 11:46:08 GMT
Dear TomEE team,


First of all, thanks for making TomEE, and making EJB accessible to all! We are greatly appreciate
your effort.


We've been using TomEE for our project for a while, and would like to give some feedbacks.


Previously, we use TomEE 1.7.4 and found a minor bug about cache header when TomEE serve javascript
files (the javascript files does not get cached by the browser), it seems that there is a
bug on cache-related http headers (the cache header always get overridden by TomEE, so we
cannot tell browser to cache the javascript files).


Then, we change to TomEE 7.0.2 and the cache header bug has been resolved. However, we think
we found a bug on SSL feature. We've setup SSL on two different machine (Redhat and CentOS)
using two different SSL certificates, and the exact same problem happen.


At first, TomEE runs normally, but after a few days (we are not exactly sure how long), TomEE
starts to have stability problem. In our case, TomEE starts to consume CPU usage (~20% on
all CPU cores) even when there is no connection. Furthermore, when users start to really use
our server (250 users, about 1 day), TomEE did crash. So, we decided to disable SSL from our
TomEE server, and everything come back to normal.


Sorry that we did not record all the problems appropriately (the time we test SSL on the 1st
and 2nd server is about 2 months), but now that we found the same problem happen on the 2nd
server. We are quite sure that TomEE has stability problem with SSL.


If you want more details or want us to help in anyway, please let us know.


Thank you and best regards,

Keerati

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message