tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From essex2014 <hamidhussain1...@gmail.com>
Subject Re: @Resource not working in tomee 1.7.4
Date Thu, 16 Feb 2017 10:58:36 GMT
I did exactly same but still the data source is null. I tried with jdk 1.6 and 1.8 as well
but no success. Can u share the war file for my example ? Just want to compare

> On 15 Feb 2017, at 14:48, Romain Manni-Bucau [via TomEE & OpenEJB] <ml-node+s979440n4681102h92@n4.nabble.com>
wrote:
> 
> just added tomee-maven-plugin version 1.7.4 to your pom and ran mvn 
> tomee:run 
> 
> 
> Romain Manni-Bucau 
> @rmannibucau <https://twitter.com/rmannibucau> |  Blog 
> <https://blog-rmannibucau.rhcloud.com> | Old Blog 
> <http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau>
| 
> LinkedIn <https://www.linkedin.com/in/rmannibucau> | JavaEE Factory 
> <https://javaeefactory-rmannibucau.rhcloud.com> 
> 
> 2017-02-15 11:12 GMT+01:00 essex2014 <[hidden email]>: 
> 
> > Hi Roman, 
> > 
> > That's really strange. Can u share me the war file you created ? Did u 
> > copy it into webapps folder in tomee ? I did not add any other jar to my 
> > tomee installation, just the defaults 
> > 
> > > On 13 Feb 2017, at 13:03, Romain Manni-Bucau [via TomEE & OpenEJB] <

> > [hidden email]> wrote: 
> > > 
> > > tested on 1.7.4 and got 
> > > 
> > > INFOS - Server startup in 2026 ms 
> > > Received: 
> > > DataSource injected: 
> > > org.apache.openejb.resource.jdbc.managed.local. 
> > ManagedDataSource@4f5991f6 
> > > 
> > > 
> > > can it be a naming issue of a dependency of something like that? 
> > > 
> > > 
> > > Romain Manni-Bucau 
> > > @rmannibucau <https://twitter.com/rmannibucau> |  Blog 
> > > <https://blog-rmannibucau.rhcloud.com> | Old Blog 
> > > <http://rmannibucau.wordpress.com> | Github <https://github.com/
> > rmannibucau> | 
> > > LinkedIn <https://www.linkedin.com/in/rmannibucau> | JavaEE Factory 
> > > <https://javaeefactory-rmannibucau.rhcloud.com> 
> > > 
> > > 2017-02-13 12:57 GMT+01:00 essex2014 <[hidden email]>: 
> > > 
> > > > Hi Roman, 
> > > > 
> > > > I have defined it in tomee.xml file. The file is committed in GitHub 
> > for 
> > > > reference. 
> > > > 
> > > > 
> > > > 
> > > > -- 
> > > > View this message in context: http://tomee-openejb.979440. 
> > > > n4.nabble.com/Resource-not-working-in-tomee-1-7-4- 
> > tp4680866p4681076.html 
> > > > Sent from the TomEE Users mailing list archive at Nabble.com. 
> > > > 
> > > 
> > > 
> > > If you reply to this email, your message will be added to the discussion 
> > below: 
> > > http://tomee-openejb.979440.n4.nabble.com/Resource-not-
> > working-in-tomee-1-7-4-tp4680866p4681081.html 
> > > To unsubscribe from @Resource not working in tomee 1.7.4, click here. 
> > > NAML 
> > 
> > 
> > 
> > 
> > -- 
> > View this message in context: http://tomee-openejb.979440. 
> > n4.nabble.com/Resource-not-working-in-tomee-1-7-4-tp4680866p4681097.html 
> > Sent from the TomEE Users mailing list archive at Nabble.com. 
> > 
> 
> 
> If you reply to this email, your message will be added to the discussion below:
> http://tomee-openejb.979440.n4.nabble.com/Resource-not-working-in-tomee-1-7-4-tp4680866p4681102.html
> To unsubscribe from @Resource not working in tomee 1.7.4, click here.
> NAML




--
View this message in context: http://tomee-openejb.979440.n4.nabble.com/Resource-not-working-in-tomee-1-7-4-tp4680866p4681105.html
Sent from the TomEE Users mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message