tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: @Resource not working in tomee 1.7.4
Date Wed, 22 Feb 2017 11:41:40 GMT
in debug (mvn tomee:debug) last time and first time i just added the
service in a rest endpoint


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<https://blog-rmannibucau.rhcloud.com> | Old Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau> | JavaEE Factory
<https://javaeefactory-rmannibucau.rhcloud.com>

2017-02-22 9:31 GMT+01:00 essex2014 <hamidhussain1973@gmail.com>:

> Thanks Roman, will try this. How did you run the project after tomee:run
> ?  Do you use that tomee plugin or just open index.jsp in browser ?
>
> > On 21 Feb 2017, at 09:24, Romain Manni-Bucau [via TomEE & OpenEJB] <
> ml-node+s979440n4681127h67@n4.nabble.com> wrote:
> >
> > use this diff
> > https://gist.github.com/rmannibucau/18e9deb57968e45556a5e422ea2f0642
> >
> > and run mvn package tomee:run
> >
> >
> > Romain Manni-Bucau
> > @rmannibucau <https://twitter.com/rmannibucau> |  Blog
> > <https://blog-rmannibucau.rhcloud.com> | Old Blog
> > <http://rmannibucau.wordpress.com> | Github <https://github.com/
> rmannibucau> |
> > LinkedIn <https://www.linkedin.com/in/rmannibucau> | JavaEE Factory
> > <https://javaeefactory-rmannibucau.rhcloud.com>
> >
> > 2017-02-21 9:31 GMT+01:00 essex2014 <[hidden email]>:
> >
> > > Hi Roman,
> > >
> > > I still can't figure out why annotations not working.
> > >
> > > Works fine in servlet
> > > Works fine using initialcontext lookup
> > >
> > > Will u be able to generate the war file again ?
> > >
> > > > On 20 Feb 2017, at 14:25, Romain Manni-Bucau [via TomEE & OpenEJB]
<
> > > [hidden email]> wrote:
> > > >
> > > > 2017-02-20 11:25 GMT+01:00 essex2014 <[hidden email]>:
> > > >
> > > > > Hi Roman/mauro2java2011,
> > > > >
> > > > > I tried both tomee.xml and context.xml and I define in either of
> them.
> > > > >
> > > > > I think the problem is with common annotations version. I am using
> jdk
> > > 1.8
> > > > > which I guess implements 1.2 commons annotations. Any idea if tomee
> > > > > supports this ?
> > > > >
> > > > >
> > > > it does
> > > >
> > > >
> > > > > Also, how can use endorsed dirs with tomee maven plugin ? I noticed
> > > that
> > > > > endorsed jars are not being copied when we execute tomee:run
> > > > >
> > > > >
> > > > yes but this is not that - using tomee 1.7 with java 8 everyday
> there and
> > > > never got that issue
> > > >
> > > >
> > > > > > On 19 Feb 2017, at 09:38, mauro2java2011 [via TomEE & OpenEJB]
<
> > > > > [hidden email]> wrote:
> > > > > >
> > > > > > I Re ad from your post:
> > > > > >
> > > > > > "configured the testDS in context.xml "
> > > > > >
> > > > > > The datasourcevis already configurate into tomee.xml
> > > > > >
> > > > > > Remo ve it from context.xml.
> > > > > >
> > > > > > If you reply to this email, your message will be added to the
> > > discussion
> > > > > below:
> > > > > > http://tomee-openejb.979440.n4.nabble.com/Resource-not-
> > > > > working-in-tomee-1-7-4-tp4680866p4681123.html
> > > > > > To unsubscribe from @Resource not working in tomee 1.7.4, click
> here.
> > > > > > NAML
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > --
> > > > > View this message in context: http://tomee-openejb.979440.
> > > > > n4.nabble.com/Resource-not-working-in-tomee-1-7-4-
> > > tp4680866p4681124.html
> > > > > Sent from the TomEE Users mailing list archive at Nabble.com.
> > > >
> > > >
> > > > If you reply to this email, your message will be added to the
> discussion
> > > below:
> > > > http://tomee-openejb.979440.n4.nabble.com/Resource-not-
> > > working-in-tomee-1-7-4-tp4680866p4681125.html
> > > > To unsubscribe from @Resource not working in tomee 1.7.4, click here.
> > > > NAML
> > >
> > >
> > >
> > >
> > > --
> > > View this message in context: http://tomee-openejb.979440.
> > > n4.nabble.com/Resource-not-working-in-tomee-1-7-4-
> tp4680866p4681126.html
> > > Sent from the TomEE Users mailing list archive at Nabble.com.
> > >
> >
> >
> > If you reply to this email, your message will be added to the discussion
> below:
> > http://tomee-openejb.979440.n4.nabble.com/Resource-not-
> working-in-tomee-1-7-4-tp4680866p4681127.html
> > To unsubscribe from @Resource not working in tomee 1.7.4, click here.
> > NAML
>
>
>
>
> --
> View this message in context: http://tomee-openejb.979440.
> n4.nabble.com/Resource-not-working-in-tomee-1-7-4-tp4680866p4681130.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message