tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: Question about web services support
Date Wed, 15 Feb 2017 10:30:00 GMT
Hi

jaxws integration behaves this way yes but thought runtime tolerated other
hosts (we did for jaxrs for sure), no blocker to fix it but this usage is
quite rare actually so never has been a priority.


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<https://blog-rmannibucau.rhcloud.com> | Old Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau> | JavaEE Factory
<https://javaeefactory-rmannibucau.rhcloud.com>

2017-02-15 11:24 GMT+01:00 Lazar Kirchev <lazar.kirchev@gmail.com>:

> Hello,
>
> I noticed that in TomcatWsRegistry's constructor the first service with
> engine container is used to initialize the registry. And after that in the
> setWsContainer this engine is used to search for the contextRoot of the
> application being deployed.
> However, it is a valid scenario to have more than one service and more than
> one engine. And if the application gets deployed on an engine different
> from the first one, which is taken in the constructor, then the deployment
> of the application fails with
> "Could not find web application context <context_root> in host <host>",
> because it is searched in the engine where it is not located.
> Is this the expected behavior?
>
> Kind regards,
> Lazar
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message