tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Cornett <adam.corn...@gmail.com>
Subject Re: problem using encrypted password with tomee and activemq
Date Wed, 15 Mar 2017 17:09:21 GMT
Thanks!

On Mar 15, 2017 12:39 PM, "Romain Manni-Bucau" <rmannibucau@gmail.com>
wrote:

> sure:
> http://tomee.apache.org/admin/configuration/resources.html#_
> value_ciphering
>
>
> Romain Manni-Bucau
> @rmannibucau <https://twitter.com/rmannibucau> |  Blog
> <https://blog-rmannibucau.rhcloud.com> | Old Blog
> <http://rmannibucau.wordpress.com> | Github <https://github.com/
> rmannibucau> |
> LinkedIn <https://www.linkedin.com/in/rmannibucau> | JavaEE Factory
> <https://javaeefactory-rmannibucau.rhcloud.com>
>
> 2017-03-15 17:38 GMT+01:00 Adam Cornett <adam.cornett@gmail.com>:
>
> > Is this syntax in the timer docs anywhere?
> >
> > On Mar 15, 2017 10:55 AM, "Romain Manni-Bucau" <rmannibucau@gmail.com>
> > wrote:
> >
> > > Hi
> > >
> > > PasswordCipher is a datasource specific  (historic) config, the generic
> > > syntax is:
> > >
> > > cipher:<algo>:<encrypted> as value so:
> > >
> > > Password = cipher:Static3DES:Gwk+x41ooEFLrKHpfSmA5g==
> > >
> > >
> > > Romain Manni-Bucau
> > > @rmannibucau <https://twitter.com/rmannibucau> |  Blog
> > > <https://blog-rmannibucau.rhcloud.com> | Old Blog
> > > <http://rmannibucau.wordpress.com> | Github <https://github.com/
> > > rmannibucau> |
> > > LinkedIn <https://www.linkedin.com/in/rmannibucau> | JavaEE Factory
> > > <https://javaeefactory-rmannibucau.rhcloud.com>
> > >
> > > 2017-03-15 14:32 GMT+01:00 racarlson <racarlson@mediacomcc.com>:
> > >
> > > > Is it possible to encrypt the activemq password with tomee. I was
> > trying
> > > > this, which worked for encrypting the jdbc datasource, but not
> working
> > > with
> > > > activemq password
> > > >
> > > > if I don't encrypt it - it works
> > > > <Resource id="MyJmsResourceAdapter" type="ActiveMQResourceAdapter">
> > > > ServerUrl
> > > > failover://(tcp://127.0.0.1:61616?wireFormat.
> > > > maxInactivityDurationInitalDelay=30000&amp;keepAlive=true)
> > > > UserName admin
> > > > Password 7GH56fdsj4(hsdf
> > > > BrokerXmlConfig no
> > > > </Resource>
> > > >
> > > > but if I use this it does not:
> > > >
> > > > <Resource id="MyJmsResourceAdapter" type="ActiveMQResourceAdapter">
> > > > ServerUrl
> > > > failover://(tcp://127.0.0.1:61616?wireFormat.
> > > > maxInactivityDurationInitalDelay=30000&amp;keepAlive=true,
> > > > tcp://nympamqv02t:61616?wireFormat.maxInactivityDurationInitalDel
> > > > ay=30000&amp;keepAlive=true)
> > > > UserName admin
> > > > PasswordCipher Static3DES
> > > > BrokerXmlConfig no
> > > > Password Gwk+x41ooEFLrKHpfSmA5g==
> > > > </Resource>
> > > >
> > > >
> > > >
> > > >
> > > > I am using this to get the encrypted password:
> > > > input>openejb -cipher -c Static3DES -e 7GH56fdsj4(hsdf
> > > > output>Gwk+x41ooEFLrKHpfSmA5g==
> > > >
> > > >
> > > >
> > > > --
> > > > View this message in context: http://tomee-openejb.979440.
> > > > n4.nabble.com/problem-using-encrypted-password-with-tomee-
> > > > and-activemq-tp4681300.html
> > > > Sent from the TomEE Users mailing list archive at Nabble.com.
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message