tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Me Self <wmso...@gmail.com>
Subject Re: Invalid response from server: -1
Date Thu, 27 Apr 2017 08:51:40 GMT
                 Line 136: [INFO] +- org.apache.openejb:arquillian-
tomee-remote:jar:1.7.4:compile

                 Line 145: [INFO] |  +- org.apache.openejb:arquillian-
tomee-common:jar:1.7.4:compile

                 Line 146: [INFO] |  +- org.apache.openejb:tomee-
common:jar:1.7.4:compile

                 Line 155: [INFO] \- org.apache.openejb:apache-
tomee:zip:plus:1.7.4:compile
                 Line 156: [INFO]    +- org.apache.openejb:tomee-util:
jar:1.7.4:compile

On Thu, Apr 27, 2017 at 10:45 AM, Romain Manni-Bucau <rmannibucau@gmail.com>
wrote:

> can you do a mvn dependency:tree | grep tomee please?
>
>
> Romain Manni-Bucau
> @rmannibucau <https://twitter.com/rmannibucau> |  Blog
> <https://blog-rmannibucau.rhcloud.com> | Old Blog
> <http://rmannibucau.wordpress.com> | Github <https://github.com/
> rmannibucau> |
> LinkedIn <https://www.linkedin.com/in/rmannibucau> | JavaEE Factory
> <https://javaeefactory-rmannibucau.rhcloud.com>
>
> 2017-04-27 10:44 GMT+02:00 Me Self <wmsopou@gmail.com>:
>
> > They are in sync
> >
> >             <properties>
> >
> >                          <tomee.version>1.7.4</tomee.version>
> >
> >                          ...
> >
> >
> >
> >
> >
> >                                      <dependencies>
> >
> >                                                   <dependency>
> >
> >                                                               <groupId>
> > org.apache.openejb</groupId>
> >
> >
>  <artifactId>
> > *arquillian*-*tomee*-remote</artifactId>
> >
> >                                                               <version>
> > ${tomee.version}</version>
> >
> >
>  <scope>test</
> > scope>
> >
> >                                                   </dependency>
> >
> >                                                   <dependency>
> >
> >                                                               <groupId>
> > org.apache.openejb</groupId>
> >
> >
>  <artifactId>
> > *apache*-*tomee*</artifactId>
> >
> >                                                               <version>
> > ${tomee.version}</version>
> >
> >
>  <classifier>
> > ${tomee.classifier}</classifier>
> >
> >
>  <type>*zip*</
> > type>
> >
> >
>  <scope>test</
> > scope>
> >
> >                                                   </dependency>
> >                                      </dependencies>
> >
> > On Thu, Apr 27, 2017 at 10:35 AM, Romain Manni-Bucau <
> > rmannibucau@gmail.com>
> > wrote:
> >
> > > check you have matching versions in your project (arquillian) and
> server,
> > > both should use 1.7.4/4.7.4 for tomee/openejb
> > >
> > >
> > > Romain Manni-Bucau
> > > @rmannibucau <https://twitter.com/rmannibucau> |  Blog
> > > <https://blog-rmannibucau.rhcloud.com> | Old Blog
> > > <http://rmannibucau.wordpress.com> | Github <https://github.com/
> > > rmannibucau> |
> > > LinkedIn <https://www.linkedin.com/in/rmannibucau> | JavaEE Factory
> > > <https://javaeefactory-rmannibucau.rhcloud.com>
> > >
> > > 2017-04-27 10:34 GMT+02:00 Me Self <wmsopou@gmail.com>:
> > >
> > > > Yes theres a "Ejb(deployment-id=openejb/Deployer)" in the server
> log.
> > > >
> > > > However I also this output when Arquillian tries to deploy:
> > > >
> > > > apr. 25, 2017 8:51:36 AM org.apache.openejb.client.EventLogger log
> > > >
> > > > INFO: RemoteInitialContextCreated{providerUri=http://localhost:
> > > > 8080/tomee/ejb}
> > > >
> > > > apr. 25, 2017 8:51:36 AM org.apache.openejb.client.EventLogger log
> > > >
> > > > WARNING: RequestFailed{server=http://localhost:8080/tomee/ejb}
> > > > JNDI_LOOKUP:/openejb/DeployerBusinessRemote {error=Prematurely
> reached
> > > the
> > > > end of the stream.  OE
> > > >
> > > > JP/4.7 : Unable to read protocol version.  Reached the end of the
> > > stream.}
> > > >
> > > > apr. 25, 2017 8:51:36 AM org.apache.openejb.client.EventLogger log
> > > >
> > > > INFO: RemoteInitialContextCreated{providerUri=http://localhost:
> > > > 8080/tomee/ejb}
> > > >
> > > > apr. 25, 2017 8:51:36 AM org.apache.openejb.client.EventLogger log
> > > >
> > > > WARNING: RequestFailed{server=http://localhost:8080/tomee/ejb}
> > > > JNDI_LOOKUP:/openejb/DeployerBusinessRemote {error=Prematurely
> reached
> > > the
> > > > end of the stream.  OE
> > > >
> > > > JP/4.7 : Unable to read protocol version.  Reached the end of the
> > > stream.}
> > > >
> > > > apr. 25, 2017 8:51:37 AM org.apache.openejb.client.EventLogger log
> > > >
> > > > INFO: RemoteInitialContextCreated{providerUri=http://localhost:
> > > > 8080/tomee/ejb}
> > > >
> > > > apr. 25, 2017 8:51:37 AM org.apache.openejb.client.EventLogger log
> > > >
> > > > WARNING: RequestFailed{server=http://localhost:8080/tomee/ejb}
> > > > JNDI_LOOKUP:/openejb/DeployerBusinessRemote {error=Prematurely
> reached
> > > the
> > > > end of the stream.  OE
> > > >
> > > > JP/4.7 : Unable to read protocol version.  Reached the end of the
> > > stream.}
> > > >
> > > > apr. 25, 2017 8:51:37 AM org.apache.openejb.client.EventLogger log
> > > >
> > > > INFO: RemoteInitialContextCreated{providerUri=http://localhost:
> > > > 8080/tomee/ejb}
> > > >
> > > > apr. 25, 2017 8:51:37 AM org.apache.openejb.client.EventLogger log
> > > >
> > > > WARNING: RequestFailed{server=http://localhost:8080/tomee/ejb}
> > > > JNDI_LOOKUP:/openejb/DeployerBusinessRemote {error=Prematurely
> reached
> > > the
> > > > end of the stream.  OE
> > > >
> > > > JP/4.7 : Unable to read protocol version.  Reached the end of the
> > > stream.}
> > > >
> > > > apr. 25, 2017 8:51:37 AM org.apache.openejb.client.EventLogger log
> > > >
> > > > INFO: RemoteInitialContextCreated{providerUri=http://localhost:
> > > > 8080/tomee/ejb}
> > > >
> > > > apr. 25, 2017 8:51:37 AM org.apache.openejb.client.EventLogger log
> > > >
> > > > WARNING: RequestFailed{server=http://localhost:8080/tomee/ejb}
> > > > JNDI_LOOKUP:/openejb/DeployerBusinessRemote {error=Prematurely
> reached
> > > the
> > > > end of the stream.  OE
> > > >
> > > > JP/4.7 : Unable to read protocol version.  Reached the end of the
> > > stream.}
> > > >
> > > > apr. 25, 2017 8:51:37 AM org.apache.openejb.arquillian.
> > > > common.TomEEContainer
> > > > undeploy
> > > > WARNING: 96d4bc59-5ff9-40ac-b4c6-78005ad6e308.war was not deployed
> > > >
> > > >
> > > >
> > > >
> > > >
> > > > On Thu, Apr 27, 2017 at 10:24 AM, Romain Manni-Bucau <
> > > > rmannibucau@gmail.com>
> > > > wrote:
> > > >
> > > > > 2017-04-27 10:07 GMT+02:00 Me Self <wmsopou@gmail.com>:
> > > > >
> > > > > > Tnx, I tried this setup from the link:
> > > > > >
> > > > > > system.conf:
> > > > > >
> > > > > > tomee.remote.support=true
> > > > > > openejb.system.apps=true
> > > > > > tomee.serialization.class.whitelist =
> > > > > > tomee.serialization.class.blacklist =
> > > > > >
> > > > > > As for the arquillian.xml file Im not sure which properties
are
> > > > relevant
> > > > > as
> > > > > > they mostly seem to address the usecase where the server is
> > > downloaded
> > > > -
> > > > > > but I already have one running. I tried these:
> > > > > >
> > > > > > <container qualifier="tomee">
> > > > > >   <configuration>
> > > > > >     <property name="httpPort">8080</property>
> > > > > >     <property name="stopPort">8005</property>
> > > > > >     <property name="version">1.7.4</property>
> > > > > >     <property name="classifier">plus</property>
> > > > > >     <property
> > > > > > name="javaagent">mvn:org.apache.sirona:sirona-
> > > > > > javaagent:0.2-incubating:jar:shaded</property>
> > > > > > </container>
> > > > > >
> > > > >
> > > > > In already installed mode the classifier and version are ignored
> (you
> > > > have
> > > > > this responsability), it is inly used when downloaded.
> > > > >
> > > > >
> > > > > >
> > > > > >
> > > > > > I get the same error as before.
> > > > > >
> > > > > > As for the instruction on the linked page to make sure tomee
> webapp
> > > and
> > > > > > ejbd is activated it still feels like something is missing
> despite
> > > > > setting
> > > > > > the properties in system.conf. There is no tomee in the webapps
> > > folder
> > > > -
> > > > > > should there be one?
> > > > > >
> > > > > >
> > > > > >
> > > > > No, the log should have something like "Ejb(...Deployer...)" if the
> > > > system
> > > > > app is activated.
> > > > >
> > > > > Do you get anything on server side in the logs?
> > > > >
> > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > On Thu, Apr 27, 2017 at 9:24 AM, Romain Manni-Bucau <
> > > > > rmannibucau@gmail.com
> > > > > > >
> > > > > > wrote:
> > > > > >
> > > > > > > Hi
> > > > > > >
> > > > > > > you should find the needed information in tomee remote
part at
> > > > > > > http://tomee.apache.org/developer/testing/arquillian/
> index.html
> > > > > > >
> > > > > > >
> > > > > > > Romain Manni-Bucau
> > > > > > > @rmannibucau <https://twitter.com/rmannibucau> |
 Blog
> > > > > > > <https://blog-rmannibucau.rhcloud.com> | Old Blog
> > > > > > > <http://rmannibucau.wordpress.com> | Github <
> https://github.com/
> > > > > > > rmannibucau> |
> > > > > > > LinkedIn <https://www.linkedin.com/in/rmannibucau>
| JavaEE
> > > Factory
> > > > > > > <https://javaeefactory-rmannibucau.rhcloud.com>
> > > > > > >
> > > > > > > 2017-04-27 9:12 GMT+02:00 Me Self <wmsopou@gmail.com>:
> > > > > > >
> > > > > > > > Hi All
> > > > > > > >
> > > > > > > > I'm trying to run an Arquillian test in TomEE Plus
1.7.4 with
> > the
> > > > > > remote
> > > > > > > > adapter but getting this error:
> > > > > > > >
> > > > > > > > Caused by: org.apache.openejb.client.ClientRuntimeException:
> > > > Invalid
> > > > > > > > response from server: -1
> > > > > > > >
> > > > > > > > The adapter does find the localhost server:
> > > > > > > >
> > > > > > > > apr. 25, 2017 8:59:52 AM
> > > > > > > > org.apache.tomee.arquillian.remote.RemoteTomEEContainer
> > > > > > > > start
> > > > > > > > INFO: TomEE found running on local port 8080
> > > > > > > >
> > > > > > > > The same test runs fine in with the TomEE embedded
adapter.
> > > > > > > >
> > > > > > > > The TomEE Plus 1.7.4 is a stock installation on localhost.
I
> > just
> > > > > > > unzipped
> > > > > > > > and ran /bin/startup.bat. Do I need to configure anything
for
> > > this
> > > > to
> > > > > > > work?
> > > > > > > > I noticed the TomEE "GUI" isnt installed out of the
box with
> > > > version
> > > > > > > 1.7.4
> > > > > > > > - does the Arquillian adapter need it?
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message