tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Gallimore <jonathan.gallim...@gmail.com>
Subject Re: IBM MQ Message property is null in MDB
Date Fri, 28 Jul 2017 10:53:31 GMT
I'm afraid this did also work for me in WMQ 8 and TomEE 7.0.2, using the
8.0.0.7 rar jars. I've included my test app and config here:
https://github.com/jgallimore/jms-test. Happy to tweak the config if it
isn't representative of your setup and try again.

I hope my test app and config is at least some help.

Jon

On Thu, Jul 27, 2017 at 5:00 PM, Jonathan Gallimore <
jonathan.gallimore@gmail.com> wrote:

> Hi
>
> This does work for me in WMQ 7.5, using the latest code in the TomEE 1.7.x
> branch. Will give it a go with TomEE 7 and WMQ 8. If that works, I'll
> provide my test app and config as a reference.
>
> Regards
>
> Jon
>
> On Wed, Jul 26, 2017 at 2:47 PM, gnanapandithan <
> m.gnanapandithan@gmail.com> wrote:
>
>> Hi jgallimore,
>>
>> Thanks for your reply. I suspect this issue due to Java EE connector api
>> and
>> resource adapter concept.
>>
>> IBM implement this by below class.
>>
>> com.ibm.mq.connector.ResourceAdapterImpl
>>
>> com.ibm.mq.connector.outbound.ManagedConnectionFactoryImpl
>>
>> I am using IBM JAR version : 8.0.0.5
>>
>>  Normal Java JMS api works fine. able to get Message property. Please try
>> with  Java EE connector api and resource adapter concept and let me know
>> if
>> it is working for you.
>>
>>
>>
>> --
>> View this message in context: http://tomee-openejb.979440.n4
>> .nabble.com/IBM-MQ-Message-property-is-null-in-MDB-tp4682317p4682325.html
>> Sent from the TomEE Users mailing list archive at Nabble.com.
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message