tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Struberg <strub...@yahoo.de.INVALID>
Subject Re: TomEE -Java EE 8 compatible or certified ?
Date Thu, 28 Sep 2017 18:15:53 GMT
Hmm, EE8 requires Java8. Just from the API alone. 
And anything compiled with Java8 will also run on Java9, right?

So I'd say the minimum requirement in TomEE8 is Java8.

Btw, we still can use Java9 for the TomEE8 development!
The new Java9 Maven build chain supports to generate real Java8 code by making use of the
new Java9 javac --release feature.

Imo we should be perfectly fine supporting Java8++ in TomEE8

LieGrue,
strub


> Am 28.09.2017 um 19:15 schrieb David Blevins <david.blevins@gmail.com>:
> 
> 
>> On Sep 27, 2017, at 3:00 AM, cocorossello <cocorossello@gmail.com> wrote:
>> 
>> Hi,
>> 
>> One question about future TomEE 8. Would it be compatible with java 9? (I
>> mean project compiled to java 9, I can run tomee 7 with java 9 runtime but I
>> have to compile to java 8).
> 
> Effectively that comes down to are we going to drop support for Java 8 in TomEE 8.  So
far that has not been discussed.
> 
> Is there something specific you're looking for from Java 9 to be leveraged in TomEE 8?
> 
> 
> -David
> 


Mime
View raw message