tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: TomEE supported on Java 9: when ?
Date Wed, 06 Dec 2017 13:29:41 GMT
@François: if it helps, EE 8 doesnt use it - and tomcat/spring doesnt
integrates it at all. It also uses more memory than a default flat
classpath. Probably don't loose time with that now. Hopefully a coming
EE version will handle it.

Romain Manni-Bucau
@rmannibucau |  Blog | Old Blog | Github | LinkedIn


2017-12-06 13:32 GMT+01:00 COURTAULT Francois <Francois.Courtault@gemalto.com>:
> Hello,
>
> Yes for sure but the path for TomEE 7.0.x (x>4) to be supported on Java 9 could be
shorter than the path to TomEE 8 / Java EE 8 /Java 9.
>
> Just for you to understand where my request comes from: we are using TomEE as the infra
for some of our µServices and quite recently we talked
> about how to optimize the memory footprint of those ones.
> One idea, I have in mind to address this issue, is to use the Java 9 modularity feature
in order to only use what is requested by TomEE and our µS: this is why ...
>
> Best Regards.
>
> -----Original Message-----
> From: Mark Struberg [mailto:struberg@yahoo.de.INVALID]
> Sent: mercredi 6 décembre 2017 13:11
> To: users@tomee.apache.org
> Subject: Re: TomEE supported on Java 9: when ?
>
> Btw, if we get a few more helping hands up then I'd be happy if someone could help me
with the TomEE8 branch ;)
>
> LieGrue,
> strub
>
>
>
>> Am 06.12.2017 um 13:08 schrieb Mark Struberg <struberg@yahoo.de>:
>>
>> I can roll an OWB-1.7.x release with Java9 support.
>>
>> LieGrue,
>> strub
>>
>>
>>> Am 06.12.2017 um 13:03 schrieb Romain Manni-Bucau <rmannibucau@gmail.com>:
>>>
>>> 2017-12-06 12:34 GMT+01:00 COURTAULT Francois <Francois.Courtault@gemalto.com>:
>>>> Hello,
>>>>
>>>> I have seen that Tomcat 8.5.24 is supported on Java 9.
>>>>
>>>> I don't see in the TomEE 7.0.5 backlog any issue about Java 9 support.
>>>
>>> No plan yet AFAIK even if xbean is now released and ready.
>>>
>>>> Nevertheless, I have seen something linked to Tomcat 8.5.23 update. Should
it be better to update directly to Tomcat 8.5.24 instead ?
>>>
>>> Should be done IMO, we generally release with the latest available
>>> tomcat, don't think this time would be different.
>>>
>>>>
>>>> Best Regards.
>>>> ________________________________
>>>> This message and any attachments are intended solely for the addressees and
may contain confidential information. Any unauthorized use or disclosure, either whole or
partial, is prohibited.
>>>> E-mails are susceptible to alteration. Our company shall not be liable for
the message if altered, changed or falsified. If you are not the intended recipient of this
message, please delete it and notify the sender.
>>>> Although all reasonable efforts have been made to keep this transmission
free from viruses, the sender will not be liable for damages caused by a transmitted virus.
>>
>
> ________________________________
>  This message and any attachments are intended solely for the addressees and may contain
confidential information. Any unauthorized use or disclosure, either whole or partial, is
prohibited.
> E-mails are susceptible to alteration. Our company shall not be liable for the message
if altered, changed or falsified. If you are not the intended recipient of this message, please
delete it and notify the sender.
> Although all reasonable efforts have been made to keep this transmission free from viruses,
the sender will not be liable for damages caused by a transmitted virus.

Mime
View raw message