trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leif Hedstrom <l...@yahoo-inc.com>
Subject Re: ubuntu build can't find tcl configuration...
Date Sun, 08 Nov 2009 05:18:28 GMT
On 11/07/2009 09:23 AM, Tom Melendez wrote:
>> Did you still have to do this with the latest (TRUNK) source? We added a
>> bunch of fixes, but I've only tried it with Ubuntu 9.10 (ad then you don't
>> need to specify the TCL dir).
>>
>> -- leif
>>      
> Yes.  Using trunk, checked out from here:
> svn co http://svn.apache.org/repos/asf/incubator/trafficserver/traffic/trunk/
>
> If I don't specify the tclconfig option configure stops with:
> WARNING: Can't find Tcl configuration definitions
>    


hmmm, i tried it on Ubuntu 8.10 (I think), and I don't get that. I 
installed the following packages, can you make sure you have all of this?

     autoconf
     libtool
     libssl-dev
     tcl-dev
     expat
     libexpat-dev
     libdb-dev


I'm hoping this will work for you, if not, please open a Jira ticket and 
attach the config.log.


However, even so, I still have compile errors, due to fwrite(). I've 
created a Jira ticket for this, with a patch:

    https://issues.apache.org/jira/browse/TS-25


If you get past the TCL issue, please give this patch above a spin.

-- Leif


Mime
View raw message