trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <.@test123.ru>
Subject Re: Basic proxy
Date Wed, 10 Nov 2010 16:09:15 GMT
Thank you very much! CONFIG proxy.config.url_remap.remap_required INT 1 is what the doctor
ordered. Trafficserver runs and works. But I cannot see log. I added <LogObject> into
log_xml.config with FileName="full/path/to/log.file". It did not create the file and no errors
in traffic.out log. How to turn on logging?

On Wed, 10 Nov 2010 10:15:51 -0500, Mark Harrison <mark@omniti.com> wrote:
> Did you set proxy.config.url_remap.remap_required to 0?
> 
> If not, then trafficserver is in reverse proxy only mode. It is that
> way by default so you don't accidentally end up running an open proxy.
> 
> In records.config, find the following line and change the 1 to a 0:
> 
> CONFIG proxy.config.url_remap.remap_required INT 1
> 
> I found that I needed to set proxy.config.reverse_proxy.enabled to 0
> also in order for transparent proxying to work.
> 
> On Wed, Nov 10, 2010 at 8:59 AM,  <a@test123.ru> wrote:
>> Hi!
>>
>> I am installing traffic server as proxy for small network. Both transparent and explicit
proxy.
>> Replacement for squid which still officially supports only HTTP/1.0. Compilation
under Ubuntu
>> 10.04 is OK, traffic server starts (locally). I cannot figure out how to connect
to the explicit
>> proxy. When I set up locahost:8080 as proxy address, I always see the page saying
site is
>> unreachable. In traffic server log there is also error message about that.
>>
>> Is there some tutorial/example of basic proxy configuration? (I read docs and wiki.)
>>
>> Thanx!
>>
>>


Mime
View raw message