trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Galić <i.ga...@brainsware.org>
Subject Re: Problem Solved: Traffic Line Not Working for Me
Date Wed, 14 Dec 2011 11:17:08 GMT


----- Original Message -----
> It was a permissions problem.  I solved it by running traffic_line as
> sudo.

Pretty sure we had a fix for that error message to say it's
not happy with your lack of privileges.
Seems we didn't back-port it.
Duh. 

> -Dan
> 
> -------- Original Message --------
> Subject: 	Traffic Line Not Working for Me
> Date: 	Tue, 13 Dec 2011 21:39:56 +0000
> From: 	Dan <dan.stone@scapps.co.uk>
> To: 	users@trafficserver.apache.org
> 
> 
> 
> Hello,
> 
> I am just getting started with Traffic Server.  I installed it using
> these instructions:
> 
> http://linuxpoison.blogspot.com/2011/07/installation-and-configuration-of.html
> 
> (correcting the version number of course).
> 
> It is working, butI don't think my installations is right.  In
> particular, traffic_line doesn't seem to work:
> 
>      dan@scapps1:/usr/local/bin$ ./traffic_line -x
>      error: the requested command failed
>      dan@scapps1:/usr/local/bin$
> 
>      dan@scapps1:/usr/local/bin$ ./traffic_line -r
>      proxy.node.hostname
>      ./traffic_line: Variable Not Found
>      dan@scapps1:/usr/local/bin$
> 
> I notice that the documentation refers to a file: /etc/traffic_server
>  I
> don't have such a file (or at least I didn't until I started
> experimenting with a file by that name it to see if I could fix my
> installation).  I'm guessing that this is related to the traffic_line
> problem in some way.
> 
> Also, I don't have seem to the start_traffic_server and
> stop_traffic_server scripts that the documentation refers to.  I have
> been using:
> 
>      sudo trafficserver start
> and
>      sudo trafficserver stop
> 
> instead.  I don't know if this could be causing the problem.
> 
> The only errors in my logs are:
> 
>      traffic.out:[Dec 13 21:19:50.214] Manager {140623480710976}
>      ERROR:
> [TrafficManager] ==>  Cleaning up and reissuing signal #3
>      traffic.out:[Dec 13 21:19:50.214] Manager {140623480710976}
>      ERROR:
> (last system error 2: No such file or directory)
> 
> which seem to happen on each shutdown.
> 
> I would greatly appreciate some advice on how to debug or fix my
> installations.
> 
> Thank you very much.
> 
> -Dan
> 
> 
> --
> 
> 
> 
> 

-- 
Igor Galić

Tel: +43 (0) 664 886 22 883
Mail: i.galic@brainsware.org
URL: http://brainsware.org/
GPG: 6880 4155 74BD FD7C B515  2EA5 4B1D 9E08 A097 C9AE


Mime
View raw message