trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geert Lugtenberg <geert.lugtenb...@poort80.nl>
Subject RE: Push Cache
Date Tue, 05 Feb 2013 13:15:27 GMT
Actually, make sure to not mix up Accept and Accept-Encoding headers. You specified Accept
header, with value */*, so any response file format is fine. But you didn't have the Accept-Encoding
header, and I think that means the pushed content is not encoded. Depending on the Vary header,
your next request for the pushed content might not be a cache hit if you have a different
Accept-Encoding request.

________________________________
Van: Rashid Zamani [rashid.z@gmail.com]
Verzonden: dinsdag 5 februari 2013 13:37
Aan: users@trafficserver.apache.org
Onderwerp: Re: Push Cache

I found what was the problem, at least I think so. Request generated by wget looks like:

GET http://www.company.com/ HTTP/1.1
User-Agent: Wget/ (linux-gnu)
Accept: */*
Host: www.company.com<http://www.company.com/>
Connection: Close
Proxy-Connection: Keep-Alive

while FireFox generated request looks like:

GET http://www.company.com/ HTTP/1.1
Host: www.company.com<http://www.company.com/>
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip, deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Proxy-Connection: keep-alive
Cookie: return=0; MTHPT="total_sessions=1&"; __utma=256864084.594601276.1359373616.1359986262.1359999517.8;
__utmz=256864084.1359373616.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)

As you can see wget accepted encoding is */* (everything) everything while FireFox asks for
only gzip and deflate. Therefore I conclude Otto was right about difference in Accept-Encoding
header.

On Mon, Feb 4, 2013 at 4:34 PM, Rashid Zamani <rashid.z@gmail.com<mailto:rashid.z@gmail.com>>
wrote:
Igor,

Thank you for your reply, and you are absolutely right, here are more details on how I'm using
ATS and what I want to get from it.

I am using trafficserver 3.2.0 as a forward proxy. And what I'm looking for is to push some
web pages into the cache, and then restore them using my browser (FireFox 7.0.1), yet I was
not able to do so.

When i try pushing a website into my ATS cache I always get the OK response, but when I try
loading the page using my browser I get the actual page not the one I pushed into the cache.
Therefore I tried using wget. With wget if I dont use --no-proxy flag I get the actual webpage
again (the "original index.html") but using wget with no flags I get the exact same materials
I push to the cache. I asked this before (not ver verboosly though) and a gentleman mentioned
that it can be because of my browser, this is his original reply, but I cant take his notes
further...
 I think your browser accepts sends an Accept-Encoding header, and the
response you pushed is not encoded. So traffic server fetches a
compressed page from your webserver, and responds with that instead.
 Regards
 Otto

So here is some part of my records.config :

CONFIG proxy.config.http.server_ports STRING 8080
CONFIG proxy.config.http.connect_ports STRING 443 563
CONFIG proxy.config.http.insert_request_via_str INT 1
CONFIG proxy.config.http.insert_response_via_str INT 0
CONFIG proxy.config.http.response_server_enabled INT 1
CONFIG proxy.config.http.insert_age_in_response INT 1
CONFIG proxy.config.http.enable_url_expandomatic INT 0
CONFIG proxy.config.http.no_dns_just_forward_to_parent INT 0
CONFIG proxy.config.http.uncacheable_requests_bypass_parent INT 1
CONFIG proxy.config.http.keep_alive_enabled_in INT 1
CONFIG proxy.config.http.keep_alive_enabled_out INT 1
CONFIG proxy.config.http.chunking_enabled INT 1
CONFIG proxy.config.http.send_http11_requests INT 1
CONFIG proxy.config.http.negative_caching_enabled INT 0
CONFIG proxy.config.http.negative_caching_lifetime INT 1800
CONFIG proxy.config.http.push_method_enabled INT 1
CONFIG proxy.config.http.cache.http INT 1
CONFIG proxy.config.http.cache.ignore_client_no_cache INT 1
CONFIG proxy.config.http.cache.ims_on_client_no_cache INT 0
CONFIG proxy.config.http.cache.ignore_server_no_cache INT 1
CONFIG proxy.config.http.cache.ignore_client_cc_max_age INT 1
CONFIG proxy.config.http.normalize_ae_gzip INT 0
CONFIG proxy.config.http.cache.cache_responses_to_cookies INT 1
CONFIG proxy.config.http.cache.ignore_authentication INT 0
CONFIG proxy.config.http.cache.cache_urls_that_look_dynamic INT 1
CONFIG proxy.config.http.cache.enable_default_vary_headers INT 0
CONFIG proxy.config.http.cache.required_headers INT 0
CONFIG proxy.config.http.cache.max_stale_age INT 604800
CONFIG proxy.config.http.cache.range.lookup INT 1
CONFIG proxy.config.cache.permit.pinning INT 1
CONFIG proxy.config.cache.ram_cache.size INT -1
CONFIG proxy.config.cache.ram_cache_cutoff INT 4194304
CONFIG proxy.config.cache.enable_read_while_writer INT 1
CONFIG proxy.config.url_remap.default_to_server_pac INT 0
CONFIG proxy.config.url_remap.default_to_server_pac_port INT -1
CONFIG proxy.config.url_remap.remap_required INT 0
CONFIG proxy.config.url_remap.pristine_host_hdr INT 1

And I only have this line uncommented in my ip_allow.config:

src_ip=127.0.0.1                                  action=ip_allow  method=ALL


Thank you for your time.



On Sun, Feb 3, 2013 at 2:04 PM, Igor Galić <i.galic@brainsware.org<mailto:i.galic@brainsware.org>>
wrote:


On Saturday, February 02, 2013 11:27:20 AM Rashid Zamani wrote:

> I have tried the following, but when I enter yahoo.com<http://yahoo.com> in my
browser, the
> Yahoo! original webpage will be load. Is it possible to tell Apache traffic
> server to load another web page instead of the original web page using push
> cache option?

Rashid,

it's pretty hard to answer your question without knowing what your
configuration looks like (forward/reverse proxy? What kind of remap rules?)

-- i



--
Rashid Zamani



--
Rashid Zamani

Mime
View raw message