trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brendan Webb <web...@ohsu.edu>
Subject Re: 406 responses being cached
Date Mon, 22 Apr 2013 22:39:27 GMT
Thanks for the idea. IIS doesn't seem to want to allow you to set custom Cache-Control headers
on the default error handler pages, but if you define a custom 406 handler, you can set your
own headers there. I did this and added some logging to capture the offending requests which
were generating 406 responses. Problem solved!



From: Conan <conanmind@gmail.com<mailto:conanmind@gmail.com>>
Reply-To: "users@trafficserver.apache.org<mailto:users@trafficserver.apache.org>" <users@trafficserver.apache.org<mailto:users@trafficserver.apache.org>>
Date: Saturday, April 6, 2013 12:44 AM
To: "users@trafficserver.apache.org<mailto:users@trafficserver.apache.org>" <users@trafficserver.apache.org<mailto:users@trafficserver.apache.org>>
Subject: Re: 406 responses being cached

On Thu, Apr 4, 2013 at 2:44 AM, Brendan Webb <webbbr@ohsu.edu<mailto:webbbr@ohsu.edu>>
wrote:
I'm running ATS 3.0.4 in front of IIS 7.5.

Is there a way to tell ATS not to cache 406 responses?

AFAIK, if you can add a "Cache-Control: no-cache" header on IIS for 406 response, ATS will
not cache it.

If unable to configure on IIS, you can try to add that header on ATS with the experimental
"header_rewrite" plugin when reading 406 response from IIS .  (You can have a try. I did't
test it and don't know if the plugin build well on your 3.0.4 environment.)

ref:
https://github.com/apache/trafficserver/tree/master/plugins/experimental/header_rewrite
https://github.com/apache/trafficserver/blob/master/plugins/experimental/header_rewrite/Examples/YCS-EC

Mime
View raw message