trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Peach <jpe...@apache.org>
Subject Re: spdy_plugin load problem
Date Sat, 08 Jun 2013 15:29:19 GMT
On Jun 6, 2013, at 10:21 PM, Avinash Uttav <uttav.avinash99@gmail.com> wrote:

> This is the FATAL message :
> 
> FATAL: spdy.cc:375: failed assert `TSNetAcceptNamedProtocol(TSContCreate(spdy_accept_io,
TSMutexCreate()), TS_NPN_PROTOCOL_SPDY_2) == TS_SUCCESS`

I'd bet that the version of OpenSSL you are using is old enough that it doesn't support the
Next Protocol Negotiation extension. If you still have the log from when you ran configure,
you would whether it was detected. I believe that NPN was added in OpenSSL 1.0.1.

Please file a bug on this, because it should log a useful message rather than asserting, <https://issues.apache.org/jira/browse/TS>

J

> 
> Last message :
> Program received signal SIGABRT, Aborted.
> 0x00007ffff5529b25 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
> 64      ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
>         in ../nptl/sysdeps/unix/sysv/linux/raise.c
> 
> 
> 
> stack trace
> /home/avinash/packages/bin/traffic_server - STACK TRACE:
> /home/avinash/packages/lib/libtsutil.so.3(ink_fatal+0xa3)[0x7ffff7bb1e85]
> /home/avinash/packages/lib/libtsutil.so.3(_Z12ink_get_randv+0x0)[0x7ffff7bb0d30]
> /home/avinash/packages/bin/traffic_server(_TSAssert+0x0)[0x4e97bb]
> /home/avinash/packages/libexec/trafficserver/spdy.so(TSPluginInit+0x12d)[0x7ffff19a9415]
> /home/avinash/packages/bin/traffic_server[0x51303e]
> /home/avinash/packages/bin/traffic_server(_Z11plugin_initPKc+0x30f)[0x513715]
> /home/avinash/packages/bin/traffic_server(main+0xef4)[0x50b010]
> /lib/libc.so.6(__libc_start_main+0xfd)[0x7ffff5514c4d]
> 
> Back trace :
> #0  0x00007ffff5529b25 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
> #1  0x00007ffff552d670 in *__GI_abort () at abort.c:92
> #2  0x00007ffff7bb1d08 in ink_die_die_die (retval=1) at ink_error.cc:43
> #3  0x00007ffff7bb1dda in ink_fatal_va (return_code=1, message_format=0x7ffff7bcca68
"%s:%d: failed assert `%s`", ap=0x7fffffffba78) at ink_error.cc:65
> #4  0x00007ffff7bb1e85 in ink_fatal (return_code=1, message_format=0x7ffff7bcca68 "%s:%d:
failed assert `%s`") at ink_error.cc:73
> #5  0x00007ffff7bb0d30 in _ink_assert (expression=0x7ffff19aba70 "TSNetAcceptNamedProtocol(TSContCreate(spdy_accept_io,
TSMutexCreate()), TS_NPN_PROTOCOL_SPDY_2) == TS_SUCCESS",
>     file=0x7ffff19ab8b9 "spdy.cc", line=375) at ink_assert.cc:38
> #6  0x00000000004e97bb in _TSReleaseAssert (text=0x7ffff19aba70 "TSNetAcceptNamedProtocol(TSContCreate(spdy_accept_io,
TSMutexCreate()), TS_NPN_PROTOCOL_SPDY_2) == TS_SUCCESS",
>     file=0x7ffff19ab8b9 "spdy.cc", line=375) at InkAPI.cc:409
> #7  0x00007ffff19a9415 in TSPluginInit (argc=1, argv=0x7fffffffcc90) at spdy.cc:373
> #8  0x000000000051303e in plugin_load (argc=1, argv=0x7fffffffcc90) at Plugin.cc:140
> #9  0x0000000000513715 in plugin_init (config_dir=0x9e4f20 "/home/avinash/packages/etc/trafficserver")
at Plugin.cc:319
> #10 0x000000000050b010 in main (argc=1, argv=0x7fffffffe6d8) at Main.cc:1716
> 
> 
> The version I m using is 
> Current (Developer/unstable )release 3.3.2 
> 
> 
> Thank u 
> 
> 
> On Thu, Jun 6, 2013 at 9:59 PM, James Peach <jpeach@apache.org> wrote:
> On Jun 5, 2013, at 11:48 PM, Avinash Uttav <uttav.avinash99@gmail.com> wrote:
> 
> > I am trying to install the spdy plugin in my ats proxy server .. but its not getting
loaded ..
> > what i did :
> > 1.make spdy
> > 2.make install
> > 3.then added the following line into
> > plugin.config :
> > spdy.so
> > 4 started traffic server in debugging session
> >
> > after passing that string line and file and line no .  to  _ink_assert function
.
> > It goes to in ink_fatal (return_code=1,message_format=0x7ffff7bcca68 "%s:%d": failed
assert '%s'")at ink_error.cc
> > then ink_fatal_va
> > then ink_die_die_die( retval= 1) at ink_error.cc
> >
> > kindly tell me if i have missed something in the installation
> 
> Since you hit an assertion, there should be a fatal log message that describes the problem,
and a stack trace. Can you post both of these, along with the version of Traffic SErver that
you are using?
> 
> J
> 
> 


Mime
View raw message