trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dudley Carr <dudley.c...@gmail.com>
Subject Re: cache miss checklist
Date Sat, 15 Jun 2013 23:53:03 GMT
The expires header looks suspect in the sample response. I would try setting it to something
sensible. 


On Saturday, June 15, 2013 at 4:20 PM, Tom Melendez wrote:

> Hey Folks,
> 
> Brought up a new ATS server, configured as a reverse proxy, and I'm seeing that none
of my requests are being cached.  Think you can help me walk through what's up?  I suspect
it's something trivial.   
> 
> Here's what I have set:
> 
> # records.config
> CONFIG proxy.config.http.uncacheable_requests_bypass_parent INT 1
> CONFIG proxy.config.http.down_server.cache_time INT 600
>    # cache control #
> CONFIG proxy.config.http.cache.http INT 1
> CONFIG proxy.config.http.cache.ignore_server_no_cache INT 1
> CONFIG proxy.config.http.cache.ignore_client_cc_max_age INT 1
> CONFIG proxy.config.http.cache.cache_responses_to_cookies INT 1
> CONFIG proxy.config.http.cache.ignore_authentication INT 0
> CONFIG proxy.config.http.cache.cache_urls_that_look_dynamic INT 1
> CONFIG proxy.config.http.cache.enable_default_vary_headers INT 0
> 
> 
> # storage.config
> var/trafficserver 1024M
> 
> # cache.config
> (all commented out)
> 
> # remap.config
> map http://my_domain http://an.ip.address.here
> 
> ###
> # typical header returned from server
> ###
> HTTP/1.1 200 OK
> Date: Sat, 15 Jun 2013 23:15:17 GMT
> Server: ATS/3.2.4
> X-Drupal-Cache: HIT
> Etag: "1371338010-0"
> X-Generator: Drupal 7 (http://drupal.org)
> Cache-Control: public, max-age=0
> Last-Modified: Sat, 15 Jun 2013 23:13:30 +0000
> Expires: Sun, 19 Nov 1978 05:00:00 GMT
> Vary: Cookie,Accept-Encoding
> Content-Type: text/html; charset=utf-8
> Age: 0
> Connection: keep-alive
> 
> 
> # cache size
>  sudo /usr/local/bin/traffic_line -r proxy.process.cache.bytes_total
> 1005346816
> 
> 
> Making the requests with curl and Chrome.  It's not that I don't get all of the pages/assets,
it's just that NONE of them ever hit the cache.  Server is on RHEL, on AWS (m1.large) running
ATS 3.2.4 that I built with the default options. 
> 
> I have the extended, common, extended2 and squid logs enabled, so I should be able to
see most everything, right?
> 
> Thanks,
> 
> Tom 


Mime
View raw message