trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alvin Lee <algr...@gmail.com>
Subject Re: regex_remap.so failing to load with ATS 3.2.4
Date Thu, 13 Jun 2013 14:55:59 GMT
It seems you were right in that the config file, maps.reg must be created
and an entry must be added in before the plugin can load successfully. I
wish the documentation had stated that as I had initially thought the
plugin would create the maps.reg file for me in the default location if I
had not specified an absolute path like it said it would in the docs.

Anyways, thank you for your help, all is working as it should now.


On Wed, Jun 12, 2013 at 4:57 PM, James Peach <jpeach@apache.org> wrote:

> On Jun 12, 2013, at 12:11 PM, Alvin Lee <algrn91@gmail.com> wrote:
>
> > I just checked those log files and nothing is being written to them at
> all. It seems as if ATS keeps trying to load this plugin over and over
> again...
> > I used "tail -f" on traffic.out when I start ATS and this same block of
> messages kept appearing:
> >
> > [Jun 12 18:41:39.997] Manager {0x7fdd4590e7e0} NOTE:
> [LocalManager::startProxy] Launching ts process
> > [TrafficServer] using root directory '/'
> > [Jun 12 18:41:40.010] Manager {0x7fdd4590e7e0} NOTE:
> [LocalManager::pollMgmtProcessServer] New process connecting fd '11'
> > [Jun 12 18:41:40.010] Manager {0x7fdd4590e7e0} NOTE:
> [Alarms::signalAlarm] Server Process born
> > [Jun 12 18:41:41.021] {0x2b7144b04ee0} STATUS: opened
> /var/log/trafficserver/diags.log
> > [Jun 12 18:41:41.021] {0x2b7144b04ee0} NOTE: updated diags config
> > [Jun 12 18:41:41.024] Server {0x2b7144b04ee0} NOTE: cache clustering
> disabled
> > [Jun 12 18:41:41.039] Server {0x2b7144b04ee0} NOTE: cache clustering
> disabled
> > [Jun 12 18:41:41.046] Server {0x2b7144b04ee0} NOTE: logging
> initialized[15], logging_mode = 3
> > [Jun 12 18:41:41.055] Server {0x2b7144b04ee0} WARNING: Failed to create
> new instance for plugin /libexec/trafficserver/regex_remap.so (not a
> TS_SUCCESS return)
>
> OK, so regex_remap is failing to load. From looking at that code, I'd say
> that it only fails when it can't load any regexes from the config file. It
> logs an error, so look in the place you have error logs pointed to
> (probably error.log).
>
> > [Jun 12 18:41:41.055] Server {0x2b7144b04ee0} WARNING: Could not add
> rule at line #169; Aborting!
> > [Jun 12 18:41:41.055] Server {0x2b7144b04ee0} WARNING: [ReverseProxy]
> Can't create new remap instance for plugin
> "/libexec/trafficserver/regex_remap.so" - Unknown plugin error at line 169
> > [Jun 12 18:41:41.055] Server {0x2b7144b04ee0} WARNING: something failed
> during BuildTable() -- check your remap plugins!
> > [Jun 12 18:41:41.055] Server {0x2b7144b04ee0} WARNING: Can not load the
> remap table, exiting out!
> > [Jun 12 18:41:41.059] Manager {0x7fdd4590e7e0} ERROR:
> [Alarms::signalAlarm] Server Process was reset
> > [Jun 12 18:41:41.059] Manager {0x7fdd4590e7e0} ERROR:  (last system
> error 2: No such file or directory)
> >
> >
> >
> > On Wed, Jun 12, 2013 at 1:49 PM, Alan M. Carroll <
> amc@network-geographics.com> wrote:
> > > Server {0x2aaabd5a6410} WARNING: Failed to create new instance for
> plugin /libexec/trafficserver/regex_remap.so (not a TS_SUCCESS return)
> >
> > Have you checked the error.log and diags.log files? There might be some
> information in there.
> >
> >
>
>

Mime
View raw message