trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brendan Webb <web...@ohsu.edu>
Subject Re: rfc5861 plugin not compiling on ATS 4.0.1
Date Wed, 09 Oct 2013 22:52:04 GMT
This is the error I get trying to compile against ATS 4.0.1, which I upgraded from 3.0.4:

$ make -f Makefile.tsxs
tsxs -v -o rfc5861.so rfc5861.c
  compiling rfc5861.c -> rfc5861.lo
cc -I/app00/trafficserver/include -g -pipe -Wall -O3 -feliminate-unused-debug-symbols -fno-strict-aliasing
-mcx16 -fpic -c rfc5861.c -o rfc5861.lo
rfc5861.c:35:22: error: ink_defs.h: No such file or directory
rfc5861.c:307: error: expected ‘;’, ‘,’ or ‘)’ before ‘ATS_UNUSED’
rfc5861.c:438: error: expected ‘;’, ‘,’ or ‘)’ before ‘ATS_UNUSED’
rfc5861.c: In function ‘rfc5861_plugin’:
rfc5861.c:616: error: ‘fetch_resource’ undeclared (first use in this function)
rfc5861.c:616: error: (Each undeclared identifier is reported only once
rfc5861.c:616: error: for each function it appears in.)
tsxs: compilation failed: cc -I/app00/trafficserver/include -g -pipe -Wall -O3 -feliminate-unused-debug-symbols
-fno-strict-aliasing -mcx16 -fpic -c rfc5861.c -o rfc5861.lo
make: *** [all] Error 1


On Tue, Oct 8, 2013 at 5:22 PM, Brendan Webb <webbbr@ohsu.edu<mailto:webbbr@ohsu.edu>>
wrote:
Wondering if anyone else has tried compiling the rfc5861 plugin against ATS 4.0.1? I just
upgraded our dev instance of ATS to 4.0.1 and can't seem to get the rfc5861 plugin working.


Brendan Webb
Web Engineer
Oregon Health & Science University

We've been able to get it to compile. What errors are you getting?

Mime
View raw message