trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From HarJin Park <harjin.p...@gmail.com>
Subject Re: 'ServerHosts' in 'logs_xml.config not work
Date Fri, 11 Apr 2014 05:21:12 GMT
Hello Zhao

My remap.config is below.

map  http://test.test.com/      http://192.168.10.100/
reverse_map      http://192.168.10.100/      http://test.test.com/
map  http://abc.abc.com <http://test.test.com/>/      http://192.168.10.200/
reverse_map      http://192.168.10.200/      http://abc.abc.com/


I'd like to separate logging abc.com and test.com

Thanks.



2014-04-11 12:09 GMT+09:00 Yongming Zhao <ming.zym@gmail.com>:

> what is in your remap if you running a reversed proxy? the logging is
> based on the remapped URI, that is the server name after remap.
>
> is that the problem?
>
> thanks
>
> - Yongming Zhao 赵永明
>
> 在 2014年4月10日,下午4:55,HarJin Park <harjin.park@gmail.com> 写道:
>
> Hi
> I'm using 4.2.0 TS, my config file is below.
>
> <LogFormat>
>  <Name = "cachelog"/>
> ....
> </LogFormat>
>
> <LogFilter>
>  <Name = "ERROR_UNKNOWN"/>
>  <Condition = "crc MATCH 90"/>
>  <Action = "REJECT"/>
> </LogFilter>
>
> <LogObject>
>  <Format = "cachelog"/>
>  <Filename = "test"/>
>  <Protocols = "http"/>
>  <ServerHosts = "test.test.com"/>
> </LogObject>
>
> There is no log file even I  did using curl 'http://test.test.com'.
> If I remove 'SeverHosts' tag, it is work well.
>
> I don't know why it's not work, plz give me some examples.
>
> Thanks.
>
>
>

Mime
View raw message