trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Peach <jpe...@apache.org>
Subject Re: The config error of records.config
Date Mon, 29 Sep 2014 00:09:09 GMT
On Sep 28, 2014, at 7:40 AM, Jay Li (jianli) <jianli@cisco.com> wrote:

> Hi, guys
> 
> When I tried to config full transparent (both inbound and outbound) for my ATS setup,
 I used the line in records.config (CONFIG proxy.config.http.server_ports STRING 8080:ipv4:tr-full,
ipv6:8080:tr-full)

space-separated, not comma-separated


https://trafficserver.readthedocs.org/en/latest/reference/configuration/records.config.en.html#proxy-config-http-server-ports

>  ,  but I got an error and  only trafficcop was running and trafficmanager and traffic_server
were both stopped.     
> 
> [ats@ats2n trafficserver]$ ps -aux | grep traffic
> Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.8/FAQ
> ats        910  0.0  0.0 103300   840 pts/3    S+   12:14   0:00 grep traffic
> ats      32652  0.0  0.0  78712  2952 ?        Ssl  12:02   0:00 /home/ats/local/trafficserver-5.0.1/bin/traffic_cop
> ats      32755  0.0  0.0 112384  1300 pts/3    T    12:06   0:00 find / -name traffic.out
> 
> 
> If I change the config  to CONFIG proxy.config.http.server_ports STRING 8080, then all
three processes are executed well.
> [ats@ats2n trafficserver]$ ps -aux | grep traffic
> Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.8/FAQ
> ats       1395  0.0  0.0  77684  2908 ?        Ss   12:20   0:00 /home/ats/local/trafficserver-5.0.1/bin/traffic_cop
> ats       1397  0.4  0.0 421988 17264 ?        Sl   12:20   0:00 /home/ats/local/trafficserver-5.0.1/bin/traffic_manager
> ats       1405  1.0  0.0 422456 43640 ?        Sl   12:20   0:00 /home/ats/local/trafficserver-5.0.1/bin/traffic_server
-M --httpport 8080:fd=7
> ats       1428  0.0  0.0 103272   804 pts/4    S+   12:21   0:00 grep traffic
> ats      32755  0.0  0.0 112384  1300 pts/3    T    12:06   0:00 find / -name traffic.out
> [ats@ats2n trafficserver]$
> 
> So, what’s wrong with my config (CONFIG proxy.config.http.server_ports STRING 8080:ipv4:tr-full,
ipv6:8080:td-full)?  I can't find the error.log file to analyse the error?  Thanks !
> [root@ats2n trafficserver]# ls -l
> total 1388
> -rw-r--r--. 1 ats ats    4191 Sep 28 12:21 diags.log
> -rw-r--r--. 1 ats ats   32660 Sep 28 12:21 manager.log
> -rw-r-----. 1 ats ats 1372493 Sep 28 12:31 traffic.out
> -rw-r--r--. 1 ats ats       0 Sep 24 04:53 traffic_server.stderr
> -rw-r--r--. 1 ats ats       0 Sep 24 04:53 traffic_server.stdout
> [root@ats2n trafficserver]#
> 
> 


Mime
View raw message