trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Carroll <solidwallofc...@yahoo-inc.com>
Subject Re: Deploying HTTP transparent proxy cache on Apache Traffic server
Date Wed, 05 Aug 2015 16:59:20 GMT
I would try enabling debug tags and using the string "tproxy". That should give you some information
about the ATS transparency setup and determine if ATS is actually coming up in transparent
mode. I would also check error.log and diags.log to see if there are any relevant messages.
 


     On Wednesday, August 5, 2015 11:45 AM, Mohamed Marzban <mohamedmarzban12@gmail.com>
wrote:
   

 Hi,

I am trying to deploy HTTP transparent proxy cache on Apache Traffic server. The scenario
consists of a client that is connected to the internet router through the ATS server. 
I am using ATS v.6.0. I configured the record.config file as follows:-CONFIG proxy.config.url_remap.remap_required
INT 0
-CONFIG proxy.config.http.server_ports STRING 8080:tr-full
-CONFIG proxy.config.log.logging_enabled INT 3-CONFIG proxy.config.log.squid_log_enabled INT
1
I followed Alan M. Carroll's iptables, ebtables and other networking commands (http://network-geographics.com/assets/docs/ApacheCon-2013.pdf )
to route the HTTP traffic through the ATS using the bridge configuration but it didn't work
with me. On tracing using wireshark at the client side, the handshaking between the server
and the client occurs but the data packets are not received by the client. Can anyone help
me with that?

On the mailing list, I found a previous thread on HTTP transparent caching that dates back
to May 2012. I used iptables DIVERT and networking commands as recommended by Saraswathi Venkataraman on
this thread: http://mail-archives.apache.org/mod_mbox/trafficserver-users/201205.mbox/%3CBB345F600CB1164AB82F077B37194D4317337487%40mumEX01.India.XoriantCorp.com%3E
The traffic passes through the ATS and the webpages are displayed properly at the client side.
When I stop the ATS, no traffic is received at the client side so I am sure it goes through
the ATS. However, nothing appears in the squid logs and most probably nothing is cached at
the ATS. How can I configure the ATS to cache the ongoing traffic and view that in the squid
log files?

Thanks, 
M. Marzban

  
Mime
View raw message