trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sudheer Vinukonda <sudhe...@yahoo-inc.com>
Subject Re: ATS slow on streaming/download speeds
Date Fri, 21 Aug 2015 14:59:32 GMT
Can you tell which ATS version you are running and if you are using any plugins (custom or
otherwise)?
Assuming you are not running any plugins, typically the latency on ATS should be mostly in
connection establishments (both incoming and outgoing). 
Your config does seem to enable persistent connections, so, that's good (you may consider
tuning the timers a bit depending on your use case though).
   
   - CONFIG proxy.config.http.keep_alive_no_activity_timeout_in INT 30
   - CONFIG proxy.config.http.keep_alive_no_activity_timeout_out INT 60

Depending on the version you are running, you will need to enable server session sharing to
make better use of persistent connections on the outbound side. On the latest version, the
settings you would need to play with is server session sharing pool. The default value for
this setting is "thread", which enables a per thread pool and in some cases (depending on
the origins), this has been known to increase the need for more outbound connections (and
latency). You may try checking if setting this to "global" helps.
Additionally, (again depending on which release you are running), you may consider enabling
SPDY (and/or H2) to support request multiplexing. Most popular browsers support one or the
other or both and at least one of these is enabled in several prod deployments.
H2 is out-of-the-box (although, not widely prod deployed/used yet), if you are running the
latest version (6.0+). To enable H2, you will need to set proxy-config-http2-enabled. To
enable SPDY, you will need to build trafficserver with spdylay as outlined here..
Thanks,
Sudheer
 


     On Friday, August 21, 2015 1:57 AM, Steven Goh <nubela@gmail.com> wrote:
   

 Hi,
I recently migrated away from Squid to ATS, while it fixed a lot of long-standing bugs we
had with Squid, we encountered an issue with download speeds, by which it is 2-4x slower.
Any recommendations on what I need to configure correct to fix the slow download speeds with
ATS?
Here's my records.config: http://pastebin.com/kPb2T4Gj
Thanks!

  
Mime
View raw message