trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Moseley <moseleym...@gmail.com>
Subject Re: Building with LuaJit 2.1
Date Tue, 11 Aug 2015 16:59:10 GMT
On Mon, Aug 10, 2015 at 7:35 PM, James Peach <jpeach@apache.org> wrote:

>
> > On Aug 10, 2015, at 4:53 PM, Mark Moseley <moseleymark@gmail.com> wrote:
> >
> > I've got trafficserver on the same box as another app that's using
> Luajit 2.1. I've been goofing with trying to get Trafficserver working with
> luajit 2.1 too, but reached the point where I figured I should ask before I
> burn any more time:
> >
> > Can Trafficserver be used with luajit 2.1? I was compiling 5.3.1 and
> it's got luajit 2.0.3 bundled right with the source. There's no configure
> option to point at a different luajit tree. I was about to start messing
> with the various LUA_* environment vars, when I realized it was time to ask
> the list.
> >
> > Any options?
>
> AFAIK the ability to choose a different Lua implementation was removed
> when LuaJIT was bundled into the main source tree.
>
>
Ok, good to know. I tried building ATS with the luajit 2.1 sources copied
into the lib/luajit directory, but that blows up during compilation.
Probably better to just get the other app working with luajit 2.0.

Out of curiosity, why is luajit bundled anyway? Installing the 'dev' luajit
packages for ubuntu/debian/centos seems pretty easy, though perhaps for
people not on those distro, might be a lot harder.

Mime
View raw message