trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mateusz Zajakala <zajak...@gmail.com>
Subject Re: [ATS 5.3.0] GZIP plugin not working?
Date Thu, 22 Oct 2015 19:11:19 GMT
Gancho,

thanks a lot for the tip on how to turn on debug mode. I did and NOW I'm
confused...

[Oct 22 21:06:51.790] Server {0x7f21f39027e0} DIAG: (gzip) INFO: normalized
accept encoding to gzip
[Oct 22 21:06:51.791] Server {0x7f21f39027e0} DIAG: (gzip) INFO:
compressible content type [text/plain; charset=UTF-8], matched on pattern
[text/*]
[Oct 22 21:06:51.791] Server {0x7f21f39027e0} DIAG: (gzip) INFO: adding
compression transform
[Oct 22 21:06:51.791] Server {0x7f21f39027e0} DIAG: (gzip) DEBUG:
[gzip.cc:292] [gzip_transform_one] gzip_transform: deflate with Z_NO_FLUSH
[Oct 22 21:06:51.791] Server {0x7f21f39027e0} DIAG: (gzip) INFO: Compressed
size 25 (bytes), Original size 5, ratio: -4.000000

Apparently the GZIP plugin does something, however still no
"Content-encoding" header in the response. I check with Firebug AND Chrome,
there is: Vary: Accept-Encoding header (it disappears when I switch off
gzip plugin) but nothing more:

   1. HTTP/1.1 200 OK Date: Thu, 22 Oct 2015 19:08:51 GMT Server: ATS/5.3.0
   Last-Modified: Thu, 22 Oct 2015 14:06:49 GMT ETag: "c-5-522b20191dfdc-df"
   Accept-Ranges: bytes Content-Type: text/plain; charset=UTF-8 Vary:
   Accept-Encoding Age: 0 Connection: keep-alive Transfer-Encoding: chunked




What could be happening? I'm running on basically out-of-the-box records
config (I changed port no) and have some remap configs present...

THanks


On Thu, Oct 22, 2015 at 7:41 PM, Gancho Tenev <gttenev@gmail.com> wrote:

> ./bin/traffic_server -T gzip

Mime
View raw message